Camera not working properly

Wolfrem68

n3wb
Joined
Dec 2, 2019
Messages
6
Reaction score
0
Location
Texas
Our church has installed a Amcrest 8 channel system. We installed all cameras, ran coaxial cable and # 7 has never worked properly. The camera shows loading, over and over without coming on. We have changed out the coaxial cable and stil have the same problem. Today , the system was gone back over this morning and cables rechecked. The camera in question, has been checked on several outputs on the hard drive with no change. Sometimes, the camera will show a picture in black/white, very blurry. For a few minutes today it presented a perfect picture, then back to nothing.
Any sugestions. The camera has been replaced with no diference in picture.
 

Hammerhead786

Getting the hang of it
Joined
Apr 23, 2018
Messages
96
Reaction score
38
Have you tried the camera in place of one of the working ones? Have you tried a short cable from the NVR to the camera?
 

jack7

Getting the hang of it
Joined
Mar 21, 2019
Messages
73
Reaction score
50
Location
USA
If you haven't done it, try calling or emailing Amcrest Support.
 

Wolfrem68

n3wb
Joined
Dec 2, 2019
Messages
6
Reaction score
0
Location
Texas
If you haven't done it, try calling or emailing Amcrest Support.
Every time I call I get some foreigner that barely speaks english. Can not get a person from US. Totally disapointing since the company isn my home state of Texas.
 

Hammerhead786

Getting the hang of it
Joined
Apr 23, 2018
Messages
96
Reaction score
38
If the camera does not work in any of the places where the others do or it does not function as the sole device on the nvr/dvr and you have swapped the cables too, then it is highly likely that the camera is at fault. Does it have a separate power supply? If so have you tried swapping that with one from another camera? If none of these things work, then your last resort is to bite the bullet and deal with Amcrest support. One other option might be to try and reload the camera's firmware if that's possible at all from the nvr/dvr.
 

jack7

Getting the hang of it
Joined
Mar 21, 2019
Messages
73
Reaction score
50
Location
USA
You said you used coaxial cable so you are probably using a DVR. What are the model numbers of the DVR and cameras? Or what is the model number of the total system you bought? That could help with commenting your problem.
 
Top