Blue Iris Andriod App - Black screens

Discussion in 'Android' started by MrRSJ, Aug 8, 2018.

Share This Page

  1. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
    Greetings!

    Just like the title, all video clips recorded and camera feeds are black. The web and server itself work perfect! I uninstalled/reinstalled the app and it's still displaying black. My Honor 8 phone is updated to the latest Andriod OS. Anything I'm missing?

    I checked to make sure it wasn't just a video issue, so I played YouTube and it worked fine. I did notice some of my MPEG 4 video clips aren't playing through MX player recorded by BlueIris. But a screen recording with the MP4 codec did work. <shrugs>

    Thoughts?
     
  2. Gert-Jan Hartwich

    Gert-Jan Hartwich n3wb

    Joined:
    May 6, 2018
    Messages:
    1
    Likes Received:
    0
    Same problem here after the Android app update from Aug 7...

    According to the change log on the play store FFMPEG was updated. That is probably the problem.

    Any solutions?
     
  3. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    25,321
    Likes Received:
    6,372
    email support so he can fix it.
     
  4. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
    I also emailed support about this issue. Just putting lots of feelers out there to make sure I didn't miss anything. Nine times out of 10, it's the user ;) FFMPEG???
     
  5. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
    Just saw the log. Yup. That updated killed the app. My wife's phone still works but she cannot take a screen shot anymore. It crashes.
     
  6. plomaris

    plomaris n3wb

    Joined:
    Jul 2, 2014
    Messages:
    27
    Likes Received:
    1
    It works on my phone, my wife's phone, and one tablet. It crashes immediately on one other tablet, and shows black screen on another tablet. I emailed support via the App Feedback option. I suggest everyone else do the same in order to get it resolved quickly.
     
  7. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
    Update. Support did email me a new Android app pkg file to test. It fixed the issue, so I'm assuming it will be in the play store soon!
     
    bp2008 and fenderman like this.
  8. dain

    dain n3wb

    Joined:
    Dec 20, 2016
    Messages:
    2
    Likes Received:
    0
    I just downloaded the new update from the google store, video working. I still need to verify push notifications because that broke for me on the previous update.

    Edit: Push notification still broken for me.
     
    Last edited: Aug 8, 2018
  9. twb010

    twb010 n3wb

    Joined:
    Aug 9, 2018
    Messages:
    2
    Likes Received:
    0
    Location:
    Texas
    Push notifications broke for me also. When I go to a camera's properties and try to send a test push, it says "Test message sent to 0 devices." Everything was working fine on Monday...not sure what the app update did to screw things up.
     
  10. plomaris

    plomaris n3wb

    Joined:
    Jul 2, 2014
    Messages:
    27
    Likes Received:
    1
    The App still crashes immediately on version 2.0.53 on two of my tables. I've used the "Report" option for each of those tablets to (hopefully) send the required information to the developer. Since I can't even get the app to come up on those tablets, I can't utilize the "Send Feedback to Support" or "Send debug information to Support" options within the app itself. Even so, when I've done that in the past, Ken has responded asking for access to my camera system. I'm not comfortable doing that, especially for a problem that is widespread and not particular to me.
     
  11. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
    They also asked me to access to my camera system. I created a temp standard user and sent them that info. I then deleted the user when the bug was fixed. Developers need this info to test code.
     
  12. plomaris

    plomaris n3wb

    Joined:
    Jul 2, 2014
    Messages:
    27
    Likes Received:
    1
    Well, in this case, I don't see how letting them access my camera system will help. The problem is with the Android app, not the desktop application. First, I'm not home to give them access. Second, as I stated in my first reply on this post, the app works fine on several of my devices. Currently, it only does not work on two tablets. That proves it is not a desktop application issue, but an app issue with certain types of devices, namely some tablets. So, the developers can use any desktop system to debug, just so long as they test with similar tablets. I've utilized the REPORT option when the app crashed on both tablets, so they should have the device info.
     
  13. twb010

    twb010 n3wb

    Joined:
    Aug 9, 2018
    Messages:
    2
    Likes Received:
    0
    Location:
    Texas
    New android and server update today fixed the notifications issues
     
  14. dain

    dain n3wb

    Joined:
    Dec 20, 2016
    Messages:
    2
    Likes Received:
    0
    Thanks. both working for me now.
     
  15. MrRSJ

    MrRSJ n3wb

    Joined:
    Aug 8, 2018
    Messages:
    6
    Likes Received:
    2
    Location:
    Kansas City
  16. plomaris

    plomaris n3wb

    Joined:
    Jul 2, 2014
    Messages:
    27
    Likes Received:
    1
    App is working on all my devices now.