Blue Iris Playback 7 second freeze

Discussion in 'Troubleshooting' started by mahman, Jan 9, 2017.

Share This Page

  1. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    <SOLVED>
    Steps I took that fixed my problem, most likely the 3rd bullet that actually fixed it though.
    • Made sure I actually went to the Intel HD 4600 website to get the latest graphics driver and installed instead of the intel driver update utility as that one kept saying I had the latest driver. That might've affected the Hardware Decoding option because of an old driver
    • Deleted camera and added it back in
    • Change my computer power options in control panel > advanced power settings > Changed "Turn off hard disk after 20 minutes" to "Never" - This is probably the setting that actually did the true fixing


    I didn't want to hijack the other threads so started my own. I have read all other of these threads on this msg board and others.. have tried clicking things on and off, hardware acceleration, adjusting the fps/iframe, etc., and I'm still getting these 7 second freezes on playback. I'm at a loss at what I have missed (I bet you it's something completely simple). My Blue Iris app is allowed through Windows Firewall, all folders regarding Blue Iris are excluded in Windows Defender. Any help would greatly be appreciated!! Thank you!

    Video System Info:
    i5-4590, 3.3ghz
    4gb ram
    windows 10 pro

    Connection is: Router > POE Switch > Camera

    Example video and settings images below:


    01 - Cam Video Settings.jpg 02 - Cam Video Settings.jpg 03 - Cam Video Settings.jpg 04 - Cam Motion Settings.jpg 05 - Cam Video Settings.jpg
     
    Last edited: Jan 23, 2017
  2. Mr-Gizmo

    Mr-Gizmo Young grasshopper

    Joined:
    May 19, 2014
    Messages:
    40
    Likes Received:
    16
    Try unselecting "Use RTSP/stream timecode" in Blue Iris -> camera properties -> Network IP camera configuration.
     
  3. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    Unselected, videos still doing the 7 second freeze.. arrrghh
     
  4. spankdog

    spankdog Getting the hang of it

    Joined:
    Sep 2, 2016
    Messages:
    127
    Likes Received:
    29
    Location:
    Atlanta
    Same problem here
     
  5. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    So after some testing.. i found out at least for me... the freeze always happens after the preconfigured record time after motion is detected.. so initially I had it to record 4 seconds before motion is detected. So the video was actually freezing after 4 seconds. I changed the setting to 10 seconds pre-motion to record.. and lo and behold.. the video froze after 10 seconds. So at least I figured out why it's freezing when it does... but now.. how the heck do I fix it from freezing after the preconfigured record time??
     
  6. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    21,201
    Likes Received:
    4,643
    uncheck "get events with pull point" in the configuration tab.
     
  7. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    Unchecked it and two videos recorded this morning still had the 7 second freeze, ugh..
     
  8. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    21,201
    Likes Received:
    4,643
    try deleting the camera and/or trying the hikvision rtsp option...if that doesnt work try using find inspect for the onvif profile.
     
  9. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    so no idea which ones of the things I changed which did it, but at the moment, the past couple days have had no freezes. Here's what I did in case it might help someone else:
    • Made sure I actually went to the Intel HD 4600 website to get the latest graphics driver and installed instead of the intel driver update utility as that one kept saying I had the latest driver. That might've affected the Hardware Decoding option because of an old driver
    • Deleted camera and added it back in
    • Change my computer power options in control panel > advanced power settings > Changed "Turn off hard disk after 20 minutes" to "Never" - This is probably the setting that actually did the true fixing
     
    Last edited: Jan 23, 2017
    fenderman likes this.
  10. smiticans

    smiticans Pulling my weight

    Joined:
    Sep 5, 2015
    Messages:
    322
    Likes Received:
    100
    I had the same issue years ago when I first set up my BI system. Go to Control Panel> Hardware and Sound> power options> edit plan settings and click on "change advanced power settings". Under "Hard Disk- Turn off Hard Disk after 20 minutes " change that to "never" and click apply.

    Windows was putting the BI storage HDD to sleep after 20 minutes of inactivity (no recordings). When BI detected motion and started to record, it would have to wait for the HDD to wake up from sleep before it could save the footage, hence the freezing in the recordings.

    @spankdog
     
    Last edited: Jan 23, 2017
    fenderman likes this.
  11. mahman

    mahman n3wb

    Joined:
    Dec 12, 2016
    Messages:
    16
    Likes Received:
    3
    Ah yes! That was one of the other changes I made in my Computer Power Options! I knew I forgot to jot down what else I changed to get it to work. I'll edit my other post in case other people might spring upon this thread to help them.
     
    fenderman and smiticans like this.
  12. spankdog

    spankdog Getting the hang of it

    Joined:
    Sep 2, 2016
    Messages:
    127
    Likes Received:
    29
    Location:
    Atlanta
    Thanks for the tip smiticans. I had tried running for a few days with the setting on and off and I didn't notice a difference. I have set it to disabled now so that I can rule the HD sleeping out for sure.