Help with Time Sync for my cameras

Discussion in 'Troubleshooting' started by nowandthen, Oct 13, 2016.

Share This Page

  1. nowandthen

    nowandthen Getting comfortable

    Joined:
    Oct 11, 2014
    Messages:
    130
    Likes Received:
    18
    I'm doing direct to disc recording. To the camera time stamps into the recordings (in another thread) I was told to do this (I rewrote this a bit from fendermans instructions, but only for a bit more clarity): Starting new thread as the other is kind of all over the place):
    To sync the times on all cameras do this (if you don’t camera times will drift):

    1. Login to a camera (repeat this procedure for all cameras)
    2. navigate to "Basic or Advanced Configuration" (left side)
    3. click System (left side)
    4. click on Time Settings tab.
    5. set "Time Sync." to the IP address of your Blue Iris server:
      1. Set "NTP Port" to 123
      2. “Interval" as desired. (1440 minutes is 24 hours which is good enough).
    Then install this "NetTime" timer server utility on your Blue Iris Server... Not doing this…
    http://www.timesynctool.com/
    Instead I am using time.windows.com. Tests ok but 1 camera has drifted a few seconds, so must not really be working.

    I downloaded NetTime (TimeSynctool.com) and installed it on my BI computer.

    I log into my camera and do as above, but put "time.windows.com" in the server address, then click test, it claims it works, but one camera has already drifted a couple of seconds over the last few days. I'm sure this is wrong.

    If I put my Blue Iris computer's IP address in the server address, then test it, it fails. NTP port is 123, Interval is 1440, not that the interval matters. Server address is 192.168... it doesn't like ":81", says illegal format or something like that. When I enter 192.168.X.X (BI computer IP address), it accepts it, but the test fails.

    What am I missing? I can be a bit dense. Once I (with your help) get it, I make a "how-to" for future reference.

    Thanks.
     
    xtropodx likes this.
  2. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    30,823
    Likes Received:
    9,793
    Allow port 123 udp through the firewall..
     
    SouthernYankee and xtropodx like this.
  3. bike_rider

    bike_rider Young grasshopper

    Joined:
    Mar 14, 2015
    Messages:
    50
    Likes Received:
    10
    I'd guess that the windows firewall on the BI machine is blocking the time server. I don't see the point of running a time server on a local machine if you have an internet connection - cameras will drift regardless of the time sort (if they are going to drift at all). I use pool.ntp.org


     
  4. avi6581

    avi6581 Getting the hang of it

    Joined:
    Nov 13, 2014
    Messages:
    99
    Likes Received:
    30
    i run a local time server on the blue iris server for the hikvision cameras to sync with , as I block all outbound traffic from my cameras at a router level. They can only talk on the local network. Don't trust the Chinese and what the cameras might be sneakily trying to talk to over the web.
     
  5. rotorwash

    rotorwash Getting the hang of it

    Joined:
    Aug 22, 2016
    Messages:
    103
    Likes Received:
    19
    Location:
    NE PA
    ^^This. I do the same thing. Let them all get time info from one source on your network.
     
  6. nowandthen

    nowandthen Getting comfortable

    Joined:
    Oct 11, 2014
    Messages:
    130
    Likes Received:
    18
    I'm not quite this paranoid but maybe because I don't know enough. :)

    If I stayed local, via the time server on the BI machine, then I am still left with "why isn't my machine updating the times?" and the test "(edit) not BI, but Hikvision camera" runs says it fails.

    I'm going to open port 123 in my firewall per fenderman's feedback. But would still like to know why the intranet solution is not working.
     
    Last edited by a moderator: Oct 14, 2016
  7. nayr

    nayr IPCT Contributor

    Joined:
    Jul 16, 2014
    Messages:
    9,347
    Likes Received:
    5,241
    Location:
    Denver, CO
    when you install TimeSync the default windows firewall will block it, you must manually configure the LOCAL WINDOWS SOFTWARE firewall to allow the NTP Server run on your LAN.
     
    xtropodx likes this.
  8. nowandthen

    nowandthen Getting comfortable

    Joined:
    Oct 11, 2014
    Messages:
    130
    Likes Received:
    18
    Thank you, I will give that a try. I set my router to allow port trigger for 123 UDP, then tested it from the Hikvision camera time setting window, it now reports that it is working.
     
  9. nowandthen

    nowandthen Getting comfortable

    Joined:
    Oct 11, 2014
    Messages:
    130
    Likes Received:
    18
    Deleted double post.
     
  10. Todd Schmidt

    Todd Schmidt Getting the hang of it

    Joined:
    May 17, 2019
    Messages:
    72
    Likes Received:
    27
    Location:
    Massachusetts
    Has anyone used NIST.gov as the time server? Tried searching and got nothing.
     
  11. SouthernYankee

    SouthernYankee IPCT Contributor

    Joined:
    Feb 15, 2018
    Messages:
    1,835
    Likes Received:
    1,028
    Location:
    Houston Tx
    use a local time server for your cameras. If use use an internet timer service you can not completely block your cameras for the internet.

    Not 100% blocking your cameras from the internet is just plan stupid.
     
    Todd Schmidt likes this.
  12. Todd Schmidt

    Todd Schmidt Getting the hang of it

    Joined:
    May 17, 2019
    Messages:
    72
    Likes Received:
    27
    Location:
    Massachusetts
    Gotcha. That makes sense.
     
  13. iseeker

    iseeker Getting the hang of it

    Joined:
    Nov 16, 2018
    Messages:
    113
    Likes Received:
    28
    Location:
    Dallas, TX
    My synology router has its own time server so i point devices on my lan to my router.
     
  14. mikeynags

    mikeynags Getting the hang of it

    Joined:
    Mar 14, 2017
    Messages:
    124
    Likes Received:
    60
    Location:
    CT - the tax you to death state
    Another good set of NTP servers brought to you by the US Navy - tick.usno.navy.mil and tock.usno.navy.mil - their IPs are 192.5.41.40 and 192.5.41.41 respectively.
     
    handinpalm likes this.