I can access router through the VPN but not further

Discussion in 'Chit-Chat' started by Thierry06410, Apr 17, 2018.

Share This Page

  1. Thierry06410

    Thierry06410 n3wb

    Joined:
    Mar 9, 2018
    Messages:
    5
    Likes Received:
    1
    Location:
    France
    I am a newbie and I've spent days going through this forum to find the good practices for a proper installation. Thanks again for the valuable information we can find here.

    But I am now stucked :

    1/ I have replaced my ISP router by a ASUS DSL-AC68U which host the VPN server and route to my LAN 10.66.66.1 / 255.255.255.0. Works fine after hours finding the proper DSL configuration.
    2/ I've disabled UPNP and port forwarding and prevented the IP camera to access outside of the LAN.
    3/ I've installed the BlueIris Server on a Dell Optiplex 5040 SFF and a Dahua test camera on this LAN. Both have a static IP adress.
    4/ I've installed OPENVPN client and the IOS version of BlueIris GUI on my Ipad and Iphone

    Everything Works fine as long as everything is on the same LAN. The VPN seems to work too as I am able to connect to the ASUS router from any locations outside the LAN.

    But BlueIris client refuse to connect BlueIris Server (says "Unable to make connection, check server address" - check done but ok ) and I can't get access to the Dahua camera using it's IP adress ("Safari cant open page as server don't answer")

    Any idea ?
     
    Last edited: Apr 17, 2018
  2. looney2ns

    looney2ns Known around here

    Joined:
    Sep 25, 2016
    Messages:
    4,572
    Likes Received:
    2,819
    Location:
    Evansville, Indiana
    Are you using the local IP address for the BI server when away from home?
    Do you have " Push Lan To Clients" checked yes, under the advanced OpenVPN settings?
    When you block the cam from contacting the internet, you won't be able to access it directly via VPN.
     
    Last edited: Apr 17, 2018
  3. Thierry06410

    Thierry06410 n3wb

    Joined:
    Mar 9, 2018
    Messages:
    5
    Likes Received:
    1
    Location:
    France
    Thks Looney
    I've booted the router, generated the ovpn client configuration, I've imported it on all my devices and it is now working...
    8 hours spent on this....Should have done this before....
     
  4. Thierry06410

    Thierry06410 n3wb

    Joined:
    Mar 9, 2018
    Messages:
    5
    Likes Received:
    1
    Location:
    France
    I was too optimistic. In fact I get back home and get connected to my LAN ... this is what has changed and make it work ... But If I get back to cellular network I still can't connect to blueiris.

    I can access to blueiris from the different clients I have (PC, Iphone, Ipad) when those clients are connected to my wifi network (the wifi network I have at home (192.168.1.x) not the one (10.66.66.x) where the blueIris server is) .
    But the connection to the blueiris server still does not work from my iphone when it is connected to the 4G network. I did not change anything in configuration between I switch from LAN to 4G.
     
  5. Thierry06410

    Thierry06410 n3wb

    Joined:
    Mar 9, 2018
    Messages:
    5
    Likes Received:
    1
    Location:
    France
    Changed the blue iris server configuration on the blueiris client :I’ve changed the default setup and specified the same IP address for LAN acess and WAN access.
    And surprise ! The client connects to the server through the vpn whatever the network type ... WiFi or cellular 4G.... Great !!!
     
    Last edited: Apr 17, 2018