Hik-Connect app playback is not smooth

GeoffC

n3wb
Joined
Sep 24, 2020
Messages
25
Reaction score
3
Location
Ontario
I've seen a number of posts on this forum regarding this issue but haven't found a resolution. I have a Hikvision nvr that supports playback of a transcoded stream (7616NI-I2/16P), but that stream doesn't appear to be used when I attempt to play back video on my Android phone through Hik-Connect. The icon for "HD/Basic" is disabled and locked to "HD". For a 4MP camera, HD simply exceeds my upload bandwidth to the web, so video playback stops/skips/etc.

On my local network, I'm able to view the transcoded video in "Live View" on my browser with no issues (I've enabled the "Smooth Streaming" option for transcoded video). My problem is viewing the transcoded video on my cell phone through Hik-Connect.
I've tried setting my recorder to record both the Main Stream and the SubStream feeds, but Hik-Connect doesn't appear to recognize the SubStream either.

Any comments/thoughts/ideas would be very much appreciated.
 

GeoffC

n3wb
Joined
Sep 24, 2020
Messages
25
Reaction score
3
Location
Ontario
I guess I'll answer my own question for future reference.

I was able to resolve this issue by switching to H.264+ encoding. I was originally using H.265+ but that left no horsepower for transcoding the stream to be streamed to my phone. I then tried H.265, and though that was better the playback was still quite choppy through Hik-Connect, even on a wired LAN connection there was still some choppiness. H.264 was much better, but curiously H.264+ gave me the "smooth as butter" playback.

I'm running 5-4MP cameras and 4-3Mp doorbell cams. With H.264+ I'm able to crank up the bitrate to a max of 8192 for the 4Mp cameras and 2048 for the doorbell cams. I can even crank up the fps to 30 for all the cameras and everything plays back smoothly.
 

GeoffC

n3wb
Joined
Sep 24, 2020
Messages
25
Reaction score
3
Location
Ontario
As an addendum to this, I've found a way to playback h265+ smoothly through Hik-Connect. I had to open a port to my server (changing it from the default of 8000 for security reasons) and then go into settings and enable DDNS. Once I did that my playback stream in Hik-Connect plays back as a "local device" (streaming directly from my NVR to the web, not through Hik servers). Alerts still come through Hik servers.

Blow by blow:

Edit: To use Hik-Connect you have to enable "platform access" in the NVR. This effectively enables DDNS through Hik servers, so steps 1) and 2) are actually not required. I tested this by disabling my ipctddns URL and Hik-Connect still works fine.
1) Set up your router for DDNS. I used ipctddns, which is free for members of ipcamtalk. For my Asus router, there are great instruction here: Asus DDNS setup
2) If you don't setup DDNS on your router, I believe that the Network settings of your NVR will let you setup DDNS on the NVR. You'll have to look up how to set that up.


3) On your Hikvision NVR, enable UPNP. This may not be completely necessary, but it was something I enabled shortly before I discovered that everything started working.
4) For security reasons, change your Server port under Network settings to something other than 8000.
5) On your router, use Port Forwarding to forward to your new server port number.
6) On Hik-Connect go to your NVR device and select the Settings icon.
7) Under the settings, select Configure DDNS.
8) Leave the Domain at its default, or select anything that has meaning to you.
9) Fill in the port info for you new server port number. You can leave the HTTP port at 80 or set it to whatever port you are using.
10) Fill in you NVR login credentials.
11) Press the Save icon to save the settings. If you see something like "Data Saved" your settings work and you're connected.

Now Hik-Connect will stream directly from your NVR even when you are away from home and h265+ should stream smoothly. Hik servers will still send you alerts but streaming will be from your NVR directly.

Note: DO NOT add your whole NVR as a "local device" in Hik-Connect because you'll no longer receive alerts. You need to add it as you would any other device (just scan the QR code) and then use the Configure DDNS setting to enable local device streaming.
 
Last edited:
Top