BlackVue DR900S-2CH - WiFi SSID Broadcast Bug

Discussion in 'Dash Cams' started by CmdrBond, Jan 26, 2019.

Share This Page

  1. CmdrBond

    CmdrBond Young grasshopper

    Joined:
    Mar 18, 2017
    Messages:
    56
    Likes Received:
    4
    Hi, back in May last year, when I got my hands on this dashcam, I noticed an issue that my phone wasn't seeing it's SSID.

    Much faffing around determined it is broadcasting 5GHz by default, and on a higher channel.

    BlackVue have, after much niggling from me (and other users after seeing my videos) have introduced a legacy mode in their firmware to force it to broadcast on 2.4GHz (But are still refusing to force it to broadcast on a lower 5.0GHz band)

    Anyway, I've just noticed we have a DashCam forum here, so I thought I'd spread the news.

    This is my post over at DashCamTalk - WiFi SSID not broadcasting - unable to connect.

    And these are the 5 videos I made. BlackVue have asked me to pull them, but I refused until they fixed the bug.









     
    atom and fenderman like this.
  2. CV350

    CV350 Young grasshopper

    Joined:
    Jan 11, 2019
    Messages:
    36
    Likes Received:
    9
    Location:
    Thailand
    That’s a lot of video to watch but Kudos to you for pushing the issue with BlackVue.

    I am not a fan of their customer support as I also haven’t had much success on the two occasions I had to seek support. I tried locally with zero success and got little support after also going direct to the manufacturer. This is a Korean brand so language can have its own issues as I quickly found.

    But I have two (older now) DR500GW’s which I am now reasonably happy with. There was some teething issues, they do run hot and issues with the memory cards, but as a basic HD recorder the setup is fine. This model has Wi-Fi but other than to periodically check that the recorder is working I don’t see the need for a constant mobile connection.

    Perhaps you will end up with the same experience as me. In the end I gave up, they eventually addressed the issues with a software update and now all is fine.

    I would purchase the same brand again albeit it was expensive at the time.
     
  3. GFM

    GFM Young grasshopper

    Joined:
    Sep 9, 2016
    Messages:
    77
    Likes Received:
    21
    Location:
    Center of Canada
    We have two older units, latest is about a year old, and have not had the wifi issue with them. In fact they were fairly easy to set up. Glad though that @CmdrBond has gone through all the trouble dealing with this problem on the new device and hopefully BlackView will fix the issue. Good to warn perspective buyers that there could be some "fun" involved.

    Just something to throw at the wall here regarding wifi; some countries have different bandplans for wifi and other wireless services. Just wondering if maybe the device had firmware installed for another country or zone, or the phone/tablet might also be using the wrong channels? Manufacturers address this through firmware for the most part, as long as you put in your country or zone. I deal with this setting up hotspots etc, making sure the right zone is selected or nothing will see it. Maybe BlackView forgot some coding for the UK/EU zone?

    Never have used the cloud service here, very poor bandwidth. Also hate to think what happens to our data when it rains... :)