Blue Iris and Google home hub

Discussion in 'General BI Talk' started by Pete_Repeat, Nov 23, 2018.

Share This Page

  1. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Reading seems to suggest this is not possible but thought I'd ask..

    I was hoping to buy a google home hub and show video feed from one of my ip cameras in the blue iris sever on motion or audio detection (baby cam)
    At the moment I am using a nexus 7 on a wireless charger stand to do this. Blue iris detects the trigger, then sends an autoremote message using eventghost from the blueiris pc, then on the nexus tablet tasker opens blue iris and shows the baby baby camera feed. Then closes blue iris and goes back to sleep.

    It works OK, although having a home hub would mean one device for Google assistant that also can be used for the display. Was hoping somehow I could cast the blue iris camera to the home hub and then stop the cast after a minute. I looked into autocast that may have been possible.

    Nithing I have read indicated this will be possible.using blue iris. Only supported cameras would work directly with Google home hub but I wanted to use blue iris and my current dahua cam.
     
    emersonvier likes this.
  2. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    I have found that using home assistant or using autocast can send the ip camera feed to the chromecast .. Except I can only make Motion jpg cast and that misses the sound and not a very good frame rate. On both ways... Hoping to get the h264 stream sent to chromecast from the blue iris Web server but I get a message saying it's the format is not supported by chromecast..
    So only option with sound I've found is using tinycam and casting it but that app is a major drain on CPU of all my devices including the s9H even so not a great option (hoping not to need a device in the middle anyway)
     
  3. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Ok so I have now found the m3u8 feed works from the Blue iris Web server to the chromecast (actually a Google Home Hub) so can now cast with audio but... There is a large delay of 20 seconds for the video. Blue iris keep making the device connected sound but I assume that's part of the process when q device is streaming m3u8
     
  4. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Shame I can't find a way to get sound to the chromecast without a large delay. I saw someone using ffmpeg but they still using mjpg with no sound
     
  5. Scarrz

    Scarrz Getting the hang of it

    Joined:
    Jul 22, 2014
    Messages:
    104
    Likes Received:
    11
    Anyway to stream the cameras from blue iris on a google chrome browser of the google home hub?
     
  6. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    I wouldn't think so.. But might check if I can cast a chrome tab to the google home hub. Hopefully it works with sound, but I don't have my high hopes.

    I will be accessing the blue iris server in a chrome browser on my PC as per usual remote access and then cast the tab..

    In saying this, using autocast on Android (using tasker) and home assistant on my raspberry pi seems to cast OK but only as mjpeg so no sound. Otherwise I'd be happy.
     
  7. Eric Quarnstrom

    Eric Quarnstrom n3wb

    Joined:
    Oct 18, 2016
    Messages:
    4
    Likes Received:
    0
    Hey Pete_Repeat

    Thanks for starting this thread and posting some of the options you've found.

    Eric Q.
     
  8. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Thanks for reminding me. I have been held up with home renovations so the google home hub is packed away... Will try the tab casting in the next week or so.

    At the moment I am leaning towards my nexus 7 2013 on a wireless charging stand which loads Blue Iris when motion is detected on the Blue Iris server PC. Anyone that wishes to do this I am happy to explain in more detail. The Home hub would be best for tidiness, but the nexus tablet has much more configuration/flexibility and with a video feed with sound and low latency.
     
  9. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Update: Casting the chrome tab does not work for me.

    Only option that works is cast the mjpeg feed which has no sound or the m3u8 feed which has sound but an extensive delay...

    For now I have run out of options and will stick with the tablet as the monitor, but hopefully in due time be able to utilise the home hub for the baby cam feed.
     
  10. Mike

    Mike Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    1,842
    Likes Received:
    1,033
    Location:
    New York
    Appreciate you trying this out...Subscribing
     
  11. dannieboiz

    dannieboiz Getting the hang of it

    Joined:
    May 13, 2015
    Messages:
    255
    Likes Received:
    24
    i'm also subscribing to this. I have a a couple Hub as well and would really like to see a solution for this.
     
  12. Pete_Repeat

    Pete_Repeat Young grasshopper

    Joined:
    May 2, 2017
    Messages:
    68
    Likes Received:
    2
    Do you need sound? As the mjpeg option works from Home Assistant on my raspberry pi, as well as Tasker on my android box.

    I need sound and no delay, which is why I am a little stuck.
     
  13. dannieboiz

    dannieboiz Getting the hang of it

    Joined:
    May 13, 2015
    Messages:
    255
    Likes Received:
    24
    Don't need sound but important that there's no delay
     
  14. Taigar

    Taigar n3wb

    Joined:
    Jan 30, 2019
    Messages:
    2
    Likes Received:
    0
    Location:
    Netherlands
    I also have the mjpeg from Home Assistant to chromecast working. But after 20 minutes, the chromecast stops showing the mjpeg. This is due to the chromecast timeout, because the state of the chromecast is 'paused' during the mjpeg viewing.

    Do you have any ideas/suggestions in how to improve this? I have setup an automation in HA to restart the mjpeg, but this will give me about 2 seconds of black screen every 20 minutes. Not a very neat solution.
     
Tags: