Motion Detection + AI - What's the secret to stop alerts when recognised objects are outside zones?

Joined
Jul 25, 2023
Messages
7
Reaction score
1
Location
New Zealand
Hi,

Just fishing.....I'm at work so have no access to home BI system, but thought I'd get a question in already to get the ball rolling. Long story short:
  1. Have a camera (obviously)
  2. Field of view split into three 'space separated' zones as follows:
    1. A - neighbor's property next to my driveway
    2. B - front of my driveway
    3. C - back of my driveway
    4. H - 'everything' zone that fill in the gaps
  3. Motion triggers when an object travels from A-B, A-C, or B-C
  4. AI is told to look for person and vehicles
  5. Alert requires zone B or C and person/vehicle
2023-09-04_10-18-31.png

Everything seems to work but I'm getting false triggers. I can tune the motion triggers OK to reduce the false triggers, but my main problem is that when triggered the AI runs and it looks for people and cars and if it finds something I get a positive alert....but this happens even if the position of that object is in Zone A which is my neighbor's property - for example just them walking to their own letter box.

In my case I think it's triggering because them walking on their drive is simply an object that moves more the 100 pixels in the sub-stream....turning that off will limit triggers to just zone crosses.... so movement in Zone A will no longer be a problem as far as additional triggers is concerned. So I can solve that part at least....

But....normally the silver car isn't there (we have visitors) but neighbor's red car (just in frame) is often parked in the location where I have placed the 'A' - regardless of when the trigger happens.....the AI when activated finds the red car in Zone A and then gives me a positive alert even though I only want alerts when the object is found in Zone B or C.

How do I run with the triggers I want, but only get alerts if the object is in the zones I want? If I limit the AI to just Zones B & C it misses most things as the image is blacked out for Zone A.

What am I missing?
 

JDreaming

Getting comfortable
Joined
Jul 21, 2020
Messages
722
Reaction score
2,132
Location
East
Use IVS rules instead of Motion Detection will cut down false alerts for you.
 

kjinxx2

Pulling my weight
Joined
Dec 1, 2020
Messages
152
Reaction score
214
Location
USA
Are you using CP.AI or Deepstack? If so you can instruct them to only look in certain zones - I think it was added to the user manual
 
Joined
Jul 25, 2023
Messages
7
Reaction score
1
Location
New Zealand
OK. I have set turned off everything in the cameras except the IVS/AI bits (so no video motion detection etc - just intrusion zone) and I've told BI to trigger only on ONVIF (so no motion zones).

Running ProjectCode.AI for the BI smart detections....should that have any/no zones checked or is that immaterial if using ONVIF/AI as the trigger?

Also, when it comes to the "monitored ONVIF alerts" the camera config detected a whole pile of ONVIF subjects during the Find/Inspect step of setting it up - are all of those valid or should some be excluded?

I have made the changes remotely....now we wait and see if I get some (or no) alerts....on paper it all seems easy, but trawling through the forum here it seems that practice and theory are often misaligned....especially if your cameras end up having firmware bugs that break IVS.....then it might be that your setup is right but it's borken elsewhere....fun times. :-(
 
Joined
Jul 25, 2023
Messages
7
Reaction score
1
Location
New Zealand
Been home. Had a play, mounted another camera. One to go.

It seems to me that the BI AI will only work if triggered by motion zones....is that right?

It's definitely not working for me at present and to get my MQTT / emails working I needed to remove all the "required object" settings from Alerts....and tick the ONVIF/DIO/External boxes....though here too I suspect I actually only need the 'External' trigger.....?

In any case I was hoping to use IVS to do some screening, then get BI AI to read the image and do it's thing. It's not that the IVS isn't working - it seems to doing just fine, BUT, without running the camera feeds through the AI I cannot read plates....I have three cameras that are surprisingly well positioned to read plates depending on where the cars go, and between them I've had reasonable success at snapping about 90% of the vehicles in the past couple of days....but now that the AI is no longer triggered nothing happens on the plate reading front. I know this has been asked before, but I can't seem to find a straight answer on the other threads....is this an either or, or can you use ONVIF/External triggers to launch the Project AI feature?

Is it otherwise an option to clone the cameras in question, set the clones not to record, and do motion-based triggering only for plates? I just want the best of both worlds....greedy I know.... ;-)
 
Top