Problems with webhooks

nabahr

n3wb
Joined
Aug 31, 2020
Messages
1
Reaction score
0
Location
Plymouth, MN, USA
I've got motion detection set up on my camera in tiny cam pro (great product btw) and it is configured to trigger a webhook on motion, but no matter what I try, I can not get the webhook to trigger.
The receiving side of the webhook is a home assistant server. I have tested the webhook manually and everything works in home assistant, it just looks like tiny cam is not sending the webhook when motion is detected.
I looked into the logs a little bit and found these lines that look all relevant to the motion and webhook triggering.

08-31 13:40:25.996 I/Event (18122): [Main Floor] In-app motion detected (0,0 - 958,1087). Motion event signalled.
08-31 13:40:26.007 I/Event (18122): Webhook sending for 'Main Floor'
08-31 13:40:26.008 I/q ( 3441): [Main Floor] 'Motion detected' event received. Total: 1
08-31 13:40:26.013 I/System.out(18122): [socket]:check permission begin!
08-31 13:40:26.013 W/System (18122): ClassLoader referenced unknown path: system/framework/mediatek-cta.jar
08-31 13:40:26.015 I/System.out(18122): [socket] e:java.lang.ClassNotFoundException: com.mediatek.cta.CtaUtils
08-31 13:40:26.040 W/okhttp.OkHttpClient(18122): A connection to was leaked. Did you forget to close a response body? To see where this was allocated, set the OkHttpClient logger level to FINE: Logger.getLogger(OkHttpClient.class.getName()).setLevel(Level.FINE);

Tinycam is running on a tablet running android 10, with tinycam version 14.7.
 
Joined
Apr 15, 2022
Messages
2
Reaction score
0
Location
India
I'm having the same issue. The webhook with ifttt works but not my local home assistant ip.

Wanted to check - is the webhook implementation making a GET request or a POST request???
 

risquare

n3wb
Joined
May 26, 2022
Messages
15
Reaction score
2
Location
Kansas
Same here. Webhook doesn't work for me. My web server is expecting GET. It does work when I test it manually from a web browser.
 
Top