Remote Viewing Android - Delayed Login and Start

Discussion in 'Troubleshooting' started by cordump2001, Sep 3, 2019.

Share This Page

  1. cordump2001

    cordump2001 n3wb

    Joined:
    Aug 24, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    United States
    Not sure if it's me, the app, or BI server. As of about two weeks ago, and without any changes to the BI server the BI android app started taking forever to log in and stream video. It can take up to a min or longer before I start seeing any video from my cameras. Sometimes it times out completely. I'm running Win10 with no firewall, port forwarded and static IP. I even disabled defender from starting in services via Reg Edit just for extra measure. I have a powerful CPU, plenty of RAM, on Gigabit network with ISP speeds of 60Mbs up and down. I have 'Use Secure Session Keys' turned off and running cameras at 15fps. I'm at a loss and starting to think its the app. Anyone else have any issues like this? Is there anything I am missing? Local viewing on my LAN works perfectly.
     
  2. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,909
    Likes Received:
    6,040
    Have you tried UI3 from the same android device? It operates similar to a mobile app, using the same authentication procedure and streaming API.
     
    fenderman likes this.
  3. looney2ns

    looney2ns IPCT Contributor

    Joined:
    Sep 25, 2016
    Messages:
    7,517
    Likes Received:
    5,908
    Location:
    Evansville, Indiana
  4. cordump2001

    cordump2001 n3wb

    Joined:
    Aug 24, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    United States
    @bp2008 Not familue with UI3. Do you access that through a web browser?

    @looney2ns I agree but was doing it to try and narrow down the culprit. It didn't seem to help so ill be turning the firewall back on. What do you suggest instead of port forwarding? I do have automatic updates turned on?
     
  5. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,909
    Likes Received:
    6,040
    Yes, just enter the same IP address and port number that you use in the app, except put them into the address bar in chrome.

    e.g. yourdomain:81
     
  6. cordump2001

    cordump2001 n3wb

    Joined:
    Aug 24, 2019
    Messages:
    3
    Likes Received:
    0
    Location:
    United States
    @bp2008 Same issue. Delayed load on camera stream.
     

    Attached Files:

  7. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,909
    Likes Received:
    6,040
    @cordump2001 See if the "Data Saver" feature there in Chrome is enabled. If it is, try turning it off. Otherwise, does your phone have any kind of antivirus or anti-spyware service on it? Those are the usual culprit for delayed streams, but I haven't heard of it on an Android device yet.