Repair db error, exclusive rights...

Joined
Sep 5, 2015
Messages
519
Reaction score
322
Do you have any virus scanners or security software installed on the computer? If not, do you have all of BI’s folders, processes, and storage drives excluded in Windows Defender?

Is BI running as a service? If so do you have it running with the admin account or as a local service?

Do you have BI setup to do automatic DB maintenance or do you do it manually?
 

bob2701

Getting comfortable
Joined
Jan 7, 2016
Messages
1,004
Reaction score
480
Location
Jersey Shore
Has been working fine for 6 plus years. Malwarebytes and Defender running and yes it is running as a service. Manual db maintenance.
This just started recently but I’m not sure when. I just replaced a EZVIZ doorbell recently, maybe I’ll remove it and run the db maint again. Will have to wait till tonight though.
Thanks for the reply, Happy Thanksgiving.
 
Joined
Sep 5, 2015
Messages
519
Reaction score
322
Are the BI folders excluded from malwarebytes, and defender?

Is BI running as a local service or did you provide it with a windows admin account credentials?

I would do a database delete and regenerate, followed by a compact and repair, then run maintenance.

Happy Thanksgiving!
 

bob2701

Getting comfortable
Joined
Jan 7, 2016
Messages
1,004
Reaction score
480
Location
Jersey Shore
I did a couple of things and now it seems ok but I will keep an eye on it.

#1 I had something hinky going on with a drive I used for “over 14 days”. It was showing a fairly large chunk as other files and as a result it also showed over allocation. There were no other files on the drive except for BI files which were in 4 hour segments. I reformatted the drive to clear everything.

#2 I did a delete and regenerate db.
The log looks clean now and I’ll check after the next couple of 4 hour dumps.

Thanks for all the help.
 

bob2701

Getting comfortable
Joined
Jan 7, 2016
Messages
1,004
Reaction score
480
Location
Jersey Shore
Just out of curiosity, when you had the original error, did that happen when you manually ran DB maintenance or did it happen randomly?
Good point, I really didn’t look other than when I ran it manually. But I just checked now and it is fine either way.
Edit.
The more I think about it it must have been from the 2am run it makes each night. I only run it manually when I see a problem.
 
Top