Save to NAS fails in BI as Service

Discussion in 'Troubleshooting' started by htiwatchmaker, Jul 25, 2019.

Share This Page

  1. htiwatchmaker

    htiwatchmaker n3wb

    Joined:
    Dec 8, 2016
    Messages:
    23
    Likes Received:
    5
    Ok. If I run BI 5.0 as a program, I can access my NAS normally for clip storage.

    If I run it as a service, I get an over allocation notice and no recording even though I set the storage locations from the drop down.

    Created a local account on the DVR which has identical credentials to the NAS BI user. Also changed the BI service log on to the BI user.

    In service, can export to NAS manually.

    The only discrepancy I see is that the Windows adds a ./ to the BI user name.

    What am I missing?

    Work around is to disable BI as service, add to startup and disable UAC for BI.

    Thanks.

    Dewey
     
  2. aristobrat

    aristobrat IPCT Contributor

    Joined:
    Dec 5, 2016
    Messages:
    2,276
    Likes Received:
    2,005
    Windows adding the ./ to the username is normal and shouldn't stop it from working.

    Any chance you have BI setup to use drive letters when referring to the NAS? That won't work for apps that run as services, you'll need to replace the drive letters with the full UNC path.
     
  3. htiwatchmaker

    htiwatchmaker n3wb

    Joined:
    Dec 8, 2016
    Messages:
    23
    Likes Received:
    5
    Thanks. Was going to try 192.168.x.xxx/Blue Iris and saw it somehow resolved. Maybe it took a reboot to reset the accounts info. But it does work using the drop down value /Diskstation/Blue Iris/New Clips.

    For clarification, I never did use a mapped drive.

    But it works and i am no longer worried about sending copies someplace off the DVR machine.
     
    aristobrat likes this.
  4. IAmATeaf

    IAmATeaf Getting comfortable

    Joined:
    Jan 13, 2019
    Messages:
    673
    Likes Received:
    318
    Location:
    United Kingdom
    You should use the UNC format of \\<NAS server>\sharename for the path in the BI config.