Working fine until Playback failed hcnetsdk.dll[5]

anima9

n3wb
Joined
Nov 11, 2022
Messages
8
Reaction score
2
Location
Philippines
Model: Ds-2CD2012F-I(W)

What happened:
1. This camera used to be unable to format and use a microsd card (128 gb), but I used another camera to do that and it was fixed.
2. Installed it again last Nov 22 and seen that it's able to record now.
3. I'm able to remote playback until Nov 23 11:59, but Nov 24 00:00 onwards, it's giving me Playback failed hcnetsdk.dll[5]. If not this error, it's "receiving data from device timed out" or "failed to receive data from the device."
4. I also can't download the videos from 24 onwards.

What I tried:
1. Rebooting (lots of times)
2. Turning all devices off except computer (using IVMS 4200 Lite and the official client)
3. Adding another user (operator)
4. Opened through ivms4500 and the hik connect app

I tried Googling my way out, but either the problem isn't fixed or the issue isn't [5]. Something happened when it changed dates that made it impossible for me to review the playback. However, it's still recording based on the screen I'm looking at + it still has current video files (which I can't download).

The one thing I haven't done is reset the camera and reformat the card, but I want that to be my last resort.

Here's an imgur link with screenshots of pertinent information.

PS: Could it be direct exposure to sunlight? I've had this camera for four years now, but it's only been exposed to direct sunlight last September 2021, but it does have a small roof above it's head, but the "lens" part is exposed because of the angle. There was also strong typhoon last November 1st week here and it hasn't been the same since.
 

niamul21

n3wb
Joined
Nov 24, 2022
Messages
1
Reaction score
0
Location
Dhaka
Model: Ds-2CD2012F-I(W)

What happened:
1. This camera used to be unable to format and use a microsd card (128 gb), but I used another camera to do that and it was fixed.
2. Installed it again last Nov 22 and seen that it's able to record now.
3. I'm able to remote playback until Nov 23 11:59, but Nov 24 00:00 onwards, it's giving me Playback failed hcnetsdk.dll[5]. If not this error, it's "receiving data from device timed out" or "failed to receive data from the device."
4. I also can't download the videos from 24 onwards.

What I tried:
1. Rebooting (lots of times)
2. Turning all devices off except computer (using IVMS 4200 Lite and the official client)
3. Adding another user (operator)
4. Opened through ivms4500 and the hik connect app

I tried Googling my way out, but either the problem isn't fixed or the issue isn't [5]. Something happened when it changed dates that made it impossible for me to review the playback. However, it's still recording based on the screen I'm looking at + it still has current video files (which I can't download).

The one thing I haven't done is reset the camera and reformat the card, but I want that to be my last resort.

Here's an imgur link with screenshots of pertinent information.

PS: Could it be direct exposure to sunlight? I've had this camera for four years now, but it's only been exposed to direct sunlight last September 2021, but it does have a small roof above it's head, but the "lens" part is exposed because of the angle. There was also strong typhoon last November 1st week here and it hasn't been the same since.
Yes, I have finally got some learning materials from this.
 

anima9

n3wb
Joined
Nov 11, 2022
Messages
8
Reaction score
2
Location
Philippines
Isn’t it more likely to be an Sd card issue?
It's a brand new SD card, which I formatted in my PC, then also in a new Hikvision camera. It's a Sandisk ultra.

What's weird is, I can definitely view the videos from Nov 22 00:00 to Nov 23 23:59, but 24 onwards, it says no more connections allowed. On the UI, I see the card is still recording and my camera is still in recording status.

I'm thinking my camera's just dead and it only temporary sprung back to life.
 
Top