Blue Iris Tools 1.6.0 sudden high CPU usage

pov2

Getting the hang of it
Joined
Sep 7, 2018
Messages
229
Reaction score
45
Location
Canada
This was reported before for the earlier version (the version number in the title is wrong): BIT 1.7 CPU usage
I decided to create a new thread because there were no ideas why this was happening.

Today I found the CPU usage was high and it looked like the BIT was using one CPU core 100%. It was still updating the weather normally, wasn't hung etc. I could see nothing wrong with it. There was no prior PC reboots (after the last one it was functioning normally). It just happened seemingly without any reason. I stopped it (normally) and started it again and all is fine.

I understand it's hard to track such bugs. What can I do to help to find out what went wrong? Are there any logs? It seems to be a recurring problem from version to version.
 

pov2

Getting the hang of it
Joined
Sep 7, 2018
Messages
229
Reaction score
45
Location
Canada
Anything in the log?
I didn't know it existed. I found it!
Unfortunately, not very helpful. It looks like this:
2/17/2020 09:10:03 Weather Update Error (xxxx) - 2/17/2020 - 09:10:03
2/17/2020 09:11:03 Weather Update Error (xxxx) - 2/17/2020 - 09:11:03
2/17/2020 09:12:03 Weather Update Error (xxxx) - 2/17/2020 - 09:12:03
2/17/2020 09:13:05 Weather Update Error (xxxx) - 2/17/2020 - 09:13:05
2/22/2020 12:48:16 No BIT update available
2/22/2020 12:48:28 Blue Iris Tools closed
2/22/2020 12:48:45 Blue Iris 5/4 detected - 'Use BlueIrisAdmin.exe' enabled
2/22/2020 12:48:47 Blue Iris Tools started

2/22/2020 - I found the PC had high CPU usage. I checked the Task Manager to see what was causing it. Checked BIT for updates, closed and reopened.
On 2/17/2020 I discovered it had stopped updating the weather. I changed the station ID and everything was fine again. There was no high CPU usage after that. I notice the CPU usage several times a day when I log out of the BI mobile app (it is shown there).
 

Mike

Staff member
Joined
Mar 9, 2014
Messages
2,844
Reaction score
2,295
Location
New York
I didn't know it existed. I found it!
Unfortunately, not very helpful. It looks like this:
2/17/2020 09:10:03 Weather Update Error (xxxx) - 2/17/2020 - 09:10:03
2/17/2020 09:11:03 Weather Update Error (xxxx) - 2/17/2020 - 09:11:03
2/17/2020 09:12:03 Weather Update Error (xxxx) - 2/17/2020 - 09:12:03
2/17/2020 09:13:05 Weather Update Error (xxxx) - 2/17/2020 - 09:13:05
2/22/2020 12:48:16 No BIT update available
2/22/2020 12:48:28 Blue Iris Tools closed
2/22/2020 12:48:45 Blue Iris 5/4 detected - 'Use BlueIrisAdmin.exe' enabled
2/22/2020 12:48:47 Blue Iris Tools started

2/22/2020 - I found the PC had high CPU usage. I checked the Task Manager to see what was causing it. Checked BIT for updates, closed and reopened.
On 2/17/2020 I discovered it had stopped updating the weather. I changed the station ID and everything was fine again. There was no high CPU usage after that. I notice the CPU usage several times a day when I log out of the BI mobile app (it is shown there).
This is actually very helpful, thanks. Gives me some clues.
 
Top