Cannot See Hikvision Live View

Joined
Mar 11, 2014
Messages
25
Reaction score
1
I have two Hikvision cameras that have worked very well for years snd I have got along without being able to see "Live View" on the cam settings. I just got a new Hikvision cam, Nelly's NSC-2X4G-DM, and again am not able to see the Live View but am able to log into the camera and use the configuration tools ok. The Configuration Image page says I need to "... download and install a plugin..." which I have done, I think it is the WebComponents.exe" file, and it seems to run ok but no help in seeing the Live View. Again, I am able to setup the cam and use it on Blue Iris ok.

I also cannot see any images using iVMS-4200.

I am using a pc base system with Windows 10 and have tried three different browsers.

I would appreciate and help from the forum members, thanks. Duane
 
Joined
Mar 11, 2014
Messages
25
Reaction score
1
Thanks Securame for the reply, but that does the same as the other browsers.
Duane
 
Joined
Mar 11, 2014
Messages
25
Reaction score
1
Thanks Alastairstevenson. I used Internet Explorer V11 and went into "Manage add-ons", not somewhere I've been before, but do not see any thing that looks like WebComponent or from HikVision. I do see something from D-Link and Shenzhen Foscam that must related to some other cams I have used but nothing from Hikvision. Somehow I must be missing something about installing the Plugin.
Duane
 
Joined
Mar 11, 2014
Messages
25
Reaction score
1
I "think" the WebComponent.exe" file is the installer but when I double click to execute or "Run as Administer" it runs, has a window to show activity, ends with the window saying "Setup has finished installing Web Component on your computer. Click Finish button." But nothing has changed, the Hikvision setup Live View is still inactive.

I just discovered another Thread discussing this subject dated 2015, titled "WebComponents.exe plug-in not compatible with Microsoft Edge Browser?". It doesn't look like a good solution to ActiveX plugin has been found for Windows 10 and I can't find another browser that works, including Internet Explorer 11.

I guess I will continue to live without "Live View".

Duane
 

fenderman

Staff member
Joined
Mar 9, 2014
Messages
35,567
Reaction score
18,305
I "think" the WebComponent.exe" file is the installer but when I double click to execute or "Run as Administer" it runs, has a window to show activity, ends with the window saying "Setup has finished installing Web Component on your computer. Click Finish button." But nothing has changed, the Hikvision setup Live View is still inactive.

I just discovered another Thread discussing this subject dated 2015, titled "WebComponents.exe plug-in not compatible with Microsoft Edge Browser?". It doesn't look like a good solution to ActiveX plugin has been found for Windows 10 and I can't find another browser that works, including Internet Explorer 11.

I guess I will continue to live without "Live View".

Duane
it does in fact work in IE...we dont have magical systems...you are doing something wrong.
it works in some other browsers like palemoon as well.
 
Joined
Mar 11, 2014
Messages
25
Reaction score
1
Problem Solved!

I contacted the camera supplier Nelly's, at Nelly's Security - The webs top source for New Security Cameras, Analog Surveillance Systems, and High Definition IP Systems. - Nelly's Security, and talked to Tech Support, Amair Ahmed. Amair was able to walk me through the steps to configure Internet Explorer to be able to Live View the camera, it took about 60 seconds to complete. I am now able to Live View the IP camera using Internet Explorer.

Amair also provided me a link in Nelly's website to describe the setup process, see H Series IP Camera How To Guides - Nelly's Security. This will bring up a bunch of Hikvision help provisions for H Series IP Cameras. On the opening page, top-left, under "QuickStart Guide" select option "03 Web Interface", then select Internet Explorer, and follow the .gif help guide. What it does is set three ActiveX Controls to "Prompt" option in Internet Explorer settings. There is also guidance for Fire Fox, Chrome, and Safari.

My thanks to Amair of Nelly's for his quick and skillful support.

Also, thanks to "alastairstevenson" above for his effort to help.

Duane
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
15,382
Reaction score
6,206
Location
Scotland
W
Amair was able to walk me through the steps to configure Internet Explorer to be able to Live View the camera, it took about 60 seconds to complete.
Well, that's good to hear.
What was the essence of it that was different from when you installed webcomponents?
 
Joined
Mar 11, 2014
Messages
25
Reaction score
1
It changes the Internet Explorer "Settings" to allow ActiveX settings to deal with the Hikvision "WebComponent.exe plugin. Beyond that I have no clue.

Duane
 
Top