OpenALPR Tool - Save and Query CSV Exports Steps I took To Get Mine Working. ZERO Programming Experience.

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
The LPR_Viewer and LPR_Downloader are free Windows programs designed by @Gymratz & @DLONG2 which allow you to automatically collect, store, view and manage plate data from your IP cameras. It does require a $5 a month subscription to the 'Watchman' plan available at OpenALPR.com.

Also there is another function built into the LPR Viewer which can pull Make, Model, Year, VIN of the vehicle which requires another $16 / month subscription details below.

Please see Original Gymratz Viewer & Download Post Here.

If. Someone is doing Fresh Install. They can download the PDF and follow the guide.

Before making any changes / Always a good idea to take a good backup of the SQL. I have now made a video tutorial on how to do backup of the SQL database. Also it does walk you thru on how to Restore SQL database if needed.


Also Latest Instructions from a Video Tutorial Now.



Once again Thank you so much to Gymratz. For putting so much time into this solution. Gymratz has now Improved / Added more features.


1) - Now you have an Ability To Manually Update / Add Make, Year ,Model, VIN.
2) - Automatic SQL Database backup.
3) - When you Load the plates Data From setting page of the viewer app. You will now be able to see the Progress / How Many Plates It is going thru.
4) - Optimized Database For Fast Loading.
5) - How it looks up a plate and do error handling in the background to use min resources.
6) - Some Bug Fixes.



Current Status - As of 6/27/2021 -
Software is Fully Operational And running. At this time Pulling Make / Model / Year From VIN is only a paid solution. Which is $16/month. This does NOT mean the software needs the subscription. You can still run it without any subscription. Only caveat You will not be able to get Make Model year info. If, You do want the subscription You can get yours from Here. Make Sure to Let them know in the message you send "$16/month API Service to supplement Gymratz - LPR Viewer."

Once again to Be clear The software will run without any subscription and will still be able to retain the plate data. Only Reason You will need a subscription is if, you want the ability to pull year, make, model etc..


People who are updating after The MAKE MODEL Info stopped do the following.

1) - Go to LPR viewer Github Page Download Latest Copy


1624721995127.png



2) - Extract The Copy.

3) - Make Sure To Unblock Files if they are blocked by Windows 10 - You can do this so by Right clicking on the file and then Go to properties - If you see unblock box Check and then hit Apply Ok.

4) Open the LPR.SLN file in Visual Studio

5) - Once the file is open Double click on app.config.


1624722094863.png




6) - You will then see the Code.

Then you basically fill out with your own info here as in the past . (Note - You can open your old "lpr.exe.config" File from bin\debug folder in Notepad, Copy and paste that info in the fields as needed)


1624836117363.png

Please Note - Highlighted Fields are new fields, That is there for Automatic SQL database Backup. You can specify where you want the SQL database backup to go.

In the example it is going to C:\Temp\

Say if you need it to go to D drive a folder called 123 Under that drive then you will just replaced the C:\Temp\ to D:\123\ You get the idea.


Once this is done.

7) - Click on Build and than Build Solution


1624722255849.png



Once this is done Test your new viewer. And replace your old copy. If you have it running as service stop the service then replace the old copy with new restart the service.

Now that the viewer is running. For those who did got the subscription. This is how you enter your API key.

1) - Go to Setting Page.
2) Enter your API Key.
3) Click Save

2021-06-27 15_45_49-Neighborhood LPR.png

1624844857758.png
 

Attachments

Last edited:

wittaj

Known around here
Joined
Apr 28, 2019
Messages
6,687
Reaction score
9,813
Location
USA
@tech101 - thank you very much for putting this together! I don't know if I will be the first to try it, but it has calmed my fears somewhat!
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
@tech101 - thank you very much for putting this together! I don't know if I will be the first to try it, but it has calmed my fears somewhat!

Hi I agree it does look intense but its not that bad. Trust me.. I just wrote it like so a 5 year old can follow it.. so lot of screen shots.. Some of them are like basic things like how to searh on google. and download and extract. But again my intention was a 5 year old should be able to follow.

Again there are few things I am working or looking for still in the viewer so that part is not the part of guide but it will be soon once I figure out.

What I want to ask someone here is also If the viewer can also do partial plate search. I am unable to do so currently will see if that is something I missed or is not the part of the program and also I was having some issue with date. But once I figure those out with @DLONG2 or someone I will put that guide too.

I do love it so far...

1584236665673.png
 
Last edited:

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
I'm running Windows 8.1 and I'm getting a "Your OS system does not support this" error for sql new.PNGSQL Server Express
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
I'm running Windows 8.1 and I'm getting a "Your OS system does not support this" error for View attachment 56721SQL Server Express
8.1 might not support this also openalpr recently did an update yesterday it has broken things for us. Currently the solution is not working and Developer is possibly working on a fix which is @DLONG2 and @Gymratz. Thank you to both of them for looking for a fix.


But again it is currently NOT working latest update of openalpr has broken things
 

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
Oh, I missed that. Ya, starting on Page 20 of the Guide, things are VERY different for me, and I followed instructions to the T.
 
Joined
Aug 1, 2018
Messages
1
Reaction score
2
Location
USA
Wow thanks for putting this together. Went through all the steps and then realized it doesn't work with the new Open ALPR update haha. Unable to download on version 2.7.103. Still, thanks for putting this together and hope we get a working version soon.
One bit of feedback on the guide is on page 34, the screenshot shows the "signing" tab selected rather than "security", although the instructions for step 6 say to choose the "security" tab.

Looking forward to the LPR viewer guide as well.
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
to the sql is w
Hi Orangelines thank you for trying it.. Also it is now working.

What we need to do is update the Camera_ID field that we have under Initial Setup Instructions.

1584227604704.png

So Open this file in a notepad or a text editor...

1584227791557.png
Hope it helps I will be putting out a viewer guide as well also thank you for pointing out the 34 I will look into it rite now and update as necessary as well..

Once again we are changing that field from smallint to int
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
Orangelines, I think that on page 34 it is suppose to be the signing and not security. Thanks ! Also I have now attached the updated Guide which include LPR Viewer hope you can get yours working today :D
 

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
I just tried this again. A few notes:

P34 should be "Signing" not Security.

P36: "Folder called Bin" should be Bin/Debug/LPR_Downloader.exe (Application)

When I launch the exe, I get a grey screen, where you have a fully populated table. It takes some time for that table to become populated, when new, I'm assuming. As I'm typing this, the table now has one entry.

What do we do with Visual Studio when we're done? Save? Close? Might want to add that in.
 
Last edited:

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
Following up, I completely missed the set-up for the Viewer. The downloader instructions say things like "Thank you" and that the viewer will be "later". Then there's nearly a full blank page, leading one to think that's the end of the road. You may want to carry on with the viewer right after, and leave the "thank you's" til the end.

Thanks for your efforts!
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
Yes It was added for the viewer later since it was having issues after the update of openalpr. Thank you for your feedback. I do see on your downloader on the original post you posted. I do not see any imported plate. This could be also because of the camera_id limit did you fix it before importing into sql ?

From the post above ?


Reason I say that is I do not see any thing being imported into sql..
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
So if the downloader was able to import it to database after license plate passed it should have looked like this.

1585847037475.png

Plates would start getting imported into database something is failing..


Start by looking into Sql Management database.

Open Sql Management Studio and hit connect so you can get connected to your Database.

1585847163669.png

Then look under

Camera_id and make sure it is showing "int"

1585847403942.png

This is something I had to troubleshoot for days. I am hoping you have ran into the same issue. If not you might have to troubleshoot 1 by 1 and see where the database import is failing. Also Your OpenALPR agent is up to date or most recent one correct ?
 

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
I just went through all the steps again, deleting last night's LPR database and starting new. Still having issues, but I'll report those over on the actual Open ALPR Tool thread. However, (and keeping in mind that I know nothing about coding) I did have a little more confusion with the instructions:

P 42, Step #5, same screenshot as the previous step. Doesn't show what "date" to click on, or where. I went with the top date box, as that's what's showing in the next step.

P44, Step #10, when clicking the date box below, I'm changing the "Value" on the right (as shown)? This wasn't the same procedure as the previous step, which was changing the max date. I'd assume I should be changing the min date, but there's no mention.

Step #11 now references the minimum date. So, should Value AND MinDate be the same (as shown)?


EDIT: I see that we both replied at the same time. I will go back and review yours right now!
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,225
Reaction score
1,377
Location
SF BayArea, USA
Yea, Same here I have zero experience in coding so took me a while to work thru lot of stuff and troubleshooting.

From my own Experience the date bug is in the viewer so that would not even be a problem in the downloader piece of things

Your database should get import first to even see anything in the viewer.

So I think take one problem at a time.. Need to figure out why your downloader is not importing to the database..
 

djmt99

Young grasshopper
Joined
Oct 13, 2015
Messages
82
Reaction score
12
So if the downloader was able to import it to database after license plate passed it should have looked like this.

View attachment 58562

Plates would start getting imported into database something is failing..
Ya, my Time/Imported/Skipped table is all grey. I had an occasional 1 here and there last night, but nothing now. For reference, what are these values indicating? Plates every -timer frequency- ?


Start by looking into Sql Management database.

Open Sql Management Studio and hit connect so you can get connected to your Database.

Then look under

Camera_id and make sure it is showing "int"
It is showing "int"
 

Attachments

Top