OpenALPR Tool - Save and Query CSV Exports

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
As per the screenshot seems like the downloader was just started and the Local Web server has not seen any cars..

Send another screenshot few mins after the car passes so we can see if those import happen from local server or csv or both after some time.. maybe give it 5-10 mins after first car passes and share that screenshot. off course leave the downloader running..
 

wittaj

IPCT Contributor
Joined
Apr 28, 2019
Messages
12,521
Reaction score
22,908
Location
USA
Yep, if you are not running this as a service, then the first time you start it, it can take awhile before you see the rows/columns on that screenshot. I had it take hours one time.
 

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
As per the screenshot seems like the downloader was just started and the Local Web server has not seen any cars..

Send another screenshot few mins after the car passes so we can see if those import happen from local server or csv or both after some time.. maybe give it 5-10 mins after first car passes and share that screenshot. off course leave the downloader running..
downlader2.jpg
 

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
Yep, if you are not running this as a service, then the first time you start it, it can take awhile before you see the rows/columns on that screenshot. I had it take hours one time.
Yes i have had it running for days and still nothing
 

wittaj

IPCT Contributor
Joined
Apr 28, 2019
Messages
12,521
Reaction score
22,908
Location
USA
OK, go to the settings page and find the webserver address and type that into a browser and does it timeout?
 

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
Since this is a first time setup. Do you see any data or plates on the viewer side ?
Yes there is data and plates on the viewer side which is being pulled from the local web server
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
That is interesting.. I can remote in with you to try to see if I can see or spot anything.. If you like.
 

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
That is interesting.. I can remote in with you to try to see if I can see or spot anything.. If you like.
Thanks for the offer but the computer is not setup for remote access at the moment
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
Thanks for the offer but the computer is not setup for remote access at the moment
Ok, Make sure though this same computer does has the access to the internet which is running the downloader copy that might be the issue.. Also try to recompile the downloader copy if that does not work run it in debug mode and see if you can capture what line of code it is failing on,.
 
Last edited:

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
Ok, Make sure though this same computer does has the access to the internet which is running the downloader copy that might be the issue.. Also try to recompile the downloader copy if that does not work run it in debug mode and see if you can capture what line of code it is failing on,.
I Changed my computer time zone to utc-6 thinking this is a time problem

downloader3.png

and it looks like i might be right
any ideas
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
Clearly it seems like you found the fix for your issue. Now not sure what time issue or bug it has... That maybe @DLONG2 or gymrat can try to see. But for now seems like 3650 data got pulled from csv so It should be good now.

not sure if your time is off on the viewer for plates if it isn't than I will just keep as is.. Did you had to change a line in the code for the time issue in the programming or just changed time on the PC to something else ??
 

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
Clearly it seems like you found the fix for your issue. Now not sure what time issue or bug it has... That maybe @DLONG2 or gymrat can try to see. But for now seems like 3650 data got pulled from csv so It should be good now.

not sure if your time is off on the viewer for plates if it isn't than I will just keep as is.. Did you had to change a line in the code for the time issue in the programming or just changed time on the PC to something else ??
Just changed time on the computer. Not a good fix though because all the times in the viewer are 6 hours out.
 
Last edited:

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
Just changed time on the computer. Not a good fix though because all the times in the viewer are 6 hours out.
Yeah so there is a bug what time zone are you in ? I think the Time convertion is somewhere in sql .. Not sure but Dlong or gym will have a better idea about a real fix..

Also you might want to read this.. I know someone else had something to do with time issue a while back. But I thought it was fixed.. Not sure now with your issue.

 
Last edited:

riluxg

Young grasshopper
Joined
Aug 1, 2015
Messages
59
Reaction score
19
Location
UK
Yeah so there is a bug what time zone are you in ? I think the Time convertion is somewhere in sql .. Not sure but Dlong or gym will have a better idea about a real fix..

Also you might want to read this.. I know someone else had something to do with time issue a while back. But I thought it was fixed.. Not sure now with your issue.

Yes i saw that but i thought Gymartz had fixed the issues in the latest update.
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
Yes i saw that but i thought Gymartz had fixed the issues in the latest update.
I thought so too that it was fixed. I am not sure if what you are having is the same issue or different.. or somewhat similar. Sounds like it is similar..
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
@riluxg Can you please let us know what time zone you are having issue with. Thank you! Also if you have any debug info... Or Event Viewer errors when your issue happens for this time bug.
 

tech101

Known around here
Joined
Mar 30, 2015
Messages
1,327
Reaction score
1,734
Location
SF BayArea, USA
@riluxg Can you change it to your normal time. Once you do please reboot the system and see if downloader than works. Thank you!
 
Top