IP Cam Talk

Welcome to the new IPCT! If you are having an issue logging in, please clear your cookies / cache.

Pre-Trigger Buffer with Sentry

BlueWave

Young grasshopper
Joined
Jan 12, 2018
Messages
32
Reaction score
16
Small observation I've noticed is that if you have your pre-trigger buffer set high (I had mine at 5 seconds) that when it sends the alert to Sentry for processing it seems to send some of the first frames in the alert which could very likely be nothing if the subject is out of frame during the pre-trigger buffer time.

When I lowered my pre-trigger buffer down to about 1 second that seemed to resolve the issue at the expense of possibly losing some video due to lag, make times....etc.
 

lifeatredline

Getting the hang of it
Joined
Jul 4, 2016
Messages
102
Reaction score
72
Location
USA
I run 5 seconds prebuffer on all my cameras. If I go out my front door quickly and off the side of the porch I am only in camera frame 2 seconds. Sentry texted an image of me right in the middle of the camera view.

Not sure exactly what sentry is using for analyses. The only place I've seen any option about including pretrigger images is in configuring email alerts where you can select or disable to include pretrigger image.
 

fenderman

Staff member
Joined
Mar 9, 2014
Messages
31,147
Reaction score
10,117
Small observation I've noticed is that if you have your pre-trigger buffer set high (I had mine at 5 seconds) that when it sends the alert to Sentry for processing it seems to send some of the first frames in the alert which could very likely be nothing if the subject is out of frame during the pre-trigger buffer time.

When I lowered my pre-trigger buffer down to about 1 second that seemed to resolve the issue at the expense of possibly losing some video due to lag, make times....etc.
Make sure your I frame interval matches your FPS. Blue Iris does not begin recording until a new i frame is sent when using direct to disc
 

BlueWave

Young grasshopper
Joined
Jan 12, 2018
Messages
32
Reaction score
16
Make sure your I frame interval matches your FPS. Blue Iris does not begin recording until a new i frame is sent when using direct to disc
I have set Blue Iris to 15fps per the "Optimizing CPU" page since I have 16 cameras... is there another setting for "i frame" intervals?
 

jrf

Getting the hang of it
Joined
Sep 12, 2017
Messages
149
Reaction score
87
Does the pre-trigger time have an effect? I have seen this also. My i-frames all match my frame rates at 15.
 

anijet

Pulling my weight
Joined
Mar 10, 2014
Messages
250
Reaction score
100
Location
CA
Does the pre-trigger time have an effect? I have seen this also. My i-frames all match my frame rates at 15.
No. At the present time the frame that is sent is the one that triggered the event, not the first frame of the recording. This may change in the future as Sentry sometimes misses recognition because the frame is too early.
 

jrf

Getting the hang of it
Joined
Sep 12, 2017
Messages
149
Reaction score
87
No. At the present time the frame that is sent is the one that triggered the event, not the first frame of the recording. This may change in the future as Sentry sometimes misses recognition because the frame is too early.
Ok, thanks. I'm seeing this pretty often, at least 50% of the time. Looking for what settings to change to help it.
 

anijet

Pulling my weight
Joined
Mar 10, 2014
Messages
250
Reaction score
100
Location
CA
If you use zone crossing the trigger will be when the target has moved into at least the second zone and should be in full view.
 

jrf

Getting the hang of it
Joined
Sep 12, 2017
Messages
149
Reaction score
87
If you use zone crossing the trigger will be when the target has moved into at least the second zone and should be in full view.
I do and it works well for triggering on motion and my setup that I use to send images to sighthound. But the images I'm getting from Sentry 50% of the time are missing the person. Unless they are slow (like my UPS guy, lol)
 

anijet

Pulling my weight
Joined
Mar 10, 2014
Messages
250
Reaction score
100
Location
CA
The image you get via SMS or email isn't the image sent to Sentry. It's the current image when BI gets the Positive back from Sentry. Usually 5-7 seconds after the trigger image. (It's the time taken to send image to Sentry, Sentry to process and send a positive back to BI and for BI to send the SMS/email.)

I'm waiting for Sentry to change this (send the trigger image) before I pay for the service.
 

jrf

Getting the hang of it
Joined
Sep 12, 2017
Messages
149
Reaction score
87
Ahhhhhh...that makes a lot more sense as to why I'm seeing that. No wonder the hit rate is so low. With my sighthound integration I save the initial image captured, if I get a hit then I SMS that image.
 

varghesesa

Sentry Rep.
Joined
Feb 1, 2019
Messages
174
Reaction score
177
Location
san jose
Getting the image right in the alerts is a high priority. Should be quickly resolved after the 5.0 release.

Thanks for sharing the zone crossing tip. I'll add it to my tips and tricks.

-- Sam from Sentry
 
Top