SMD 3.0 dahua

genelit

Getting comfortable
Joined
Jan 4, 2018
Messages
263
Reaction score
391
Location
Sweden
So, I have been testing and playing around with the new F/W.

The first I tested was the General / AI Codec. I have problem to get the the settings to "stick", the problem is probably caused by the NVR (and yes, I know what forum thread I will be recommended to follow :) ).

Before going in to the actual AI stuff.
For some cameras I like to save screenshots, good for catching plates on passing cars that I upload to a FTP-Server.
I noticed that the FTP-section was updated with some new features added.

You can "tailor" your folder structure and the best part is that you can also "tweak" the file names.
One example is that you can see what caused the snapshot.
Notice the file name on these examples.

Motion Alarm: 20210412171613_[M][0@0][0].jpg (note the bold "0")
IVS Alarm: 20210412171613_[M][0@0][1].jpg (note the bold "1")

FTP Settings.png

I saw in the notes that SMD 3.0 should be able to filter out horses. The camera is mounted where my wife walks the horses every day, in and out the stable. So, this is a good spot to see if it "works".
Actually I have one IVS tripwire alert, with SMD enabled, that was very likely caused by horse but now recording is turned on as well for some "proof" :)

Other than that no problem with stability or general bugs.
 
Last edited:

Wildcat_1

Known around here
Joined
Dec 9, 2018
Messages
1,737
Reaction score
4,663
Location
US
Testing this on B5442, T5442, 5442 vari turret & 5241-Z12 currently. Good news on Z12 is it doesn’t disable the manual focus that I mentioned we gained in the last FW release. Will be testing performance of the FW and report back

One important thing to note (and a heads up) is that the FW for the 5442s does enable Auto Iris by default which I would highly recommend you turn off. Also if you upgrade without doing a factory reset then the Noise Reduction (NR) gets reset to 30 while other settings remain intact.
 

wittaj

IPCT Contributor
Joined
Apr 28, 2019
Messages
13,387
Reaction score
24,957
Location
USA
Andy asked me to test this with the 5241-Z12E and Blue Iris since this has a new encoding strategy and we know that Smart Codec can be problematic with Blue Iris.

Personally, I have never had an issue with the AI in these cameras and have always been spot on, and believe in the don't fix what ain't broke mentality, but thought I would give it a try on the older model camera.

First thing I noticed when I updated was it asked for a plug-in. Thought those days were gone LOL.

When I changed it to the AI Codec, it now forces your to use iframe interval of the FPS or twice the FPS - those are the only two options.

Fortunately I have a few runners and walkers go by like clockwork so I could pull them up from previous days to compare.

I have ran it for 24 hours now and it all appears to be running fine with Blue Iris, with an exception that may or may not be an issue for you.

With SMD, the recognition of the subject is delayed compared to previously. I suspect that is in part due to additional analysis being performed. It still recorded on every event, but in many instances, the vehicle would have moved all the way across the screen and be half a car from outside of the field of view all together before the vehicle would get the AI box around it (so actually a half a box). Previously it would draw the box around the whole car when it was in the center of the frame.

I do not know if this update also impacted IVS AI, but it did in mine. Similar things happened as with SMD. Previously, the camera would trigger on the leading edge of the box around a person. Now the person is completely through the IVS before it would trigger. It still got them and triggered, but was delayed.

This impacts if you use it as a spotter cam for a PTZ. The jogger would be almost out of the field of view before the IVS triggered well beyond the jogger crossing the line right in the middle of the field of view. This impacted the spotter cam in that by the time the camera recognized it as a person and sent the command to BI for an ONVIF trigger and then the PTZ would move, the jogger was out of the frame. This did not happen previously.

And here is an interesting issue. Switching back and forth between SMD and IVS changes the shutter speed and iris. I am enabling and disabling right now and watching the screen darken and then go into the exposure and I am watching the shutter speed and iris change. IVS is a 6.66ms shutter and 70 iris. Change to SMD and it goes to 8.33ms and 95 iris. Switch back to IVS and back to 6.66ms shutter and 70 iris.

It will be interesting to see what results @Wildcat_1 gets with this camera. I am so happy with the AI performance on my 5442-Z4E that I am not risking this update for it. I will give this a few more days on the Z12E and maybe try 3 factory resets LOL and see if anything changes.
 

Wildcat_1

Known around here
Joined
Dec 9, 2018
Messages
1,737
Reaction score
4,663
Location
US
All

I've completed tested with the cams tonight and spent time re-visiting the 5442 on this new SMD3.0 FW. Lets talk about SMD and IR separately on 5442 for main coverage then I'll quickly cover the 5241.

Auto IR vs Smart IR

First and I have to say the IR (now Auto IR, no SmartIR) is TERRIBLE :( It unfortunately takes the FW back to code in place before I had given the feedback I did with my Night Performance testing that with others feedback too, led to the 11/23 and 12/03 improved releases. I will post some video tomorrow so you can see the difference but to illustrate, I took 2 quick screen grabs (hence the poor quality but they still show the difference).​
Both versions of FW were set to identical settings which are. Range of 4 - 16.67 (1/60 to 1/250), no Auto Iris, gain left at 0-50 (default) and In the case of SMD 3.0 FW IR is set to Auto. In the case of the 11/23 FW its exactly the same settings except Smart IR is on. In both cases I look directly at the camera. Take a look​
SMD 3.0 Screen Grab - Auto IR
New SMD 3-0 FW on 5442 Running 1-60 to 1-250 with Auto IR.jpg
Old 11/23 FW - Smart IR
Old 11-23 FW on 5442 Running 1-60 to 1-250 with Smart IR.jpg
I think the pics speak for themselves. A real shame that the code was reverted BUT I've fed this back to Dahua and to @EMPIRETECANDY and am sure this will be easy to resolve by using the 11/23 and 12/03 SmartIR code and combining into this 3.0 release.​


SMD 3.0 - AI

With regards to the SMD AI detection (specifically referencing distance of detection here), I've actually found this works very well in this new release. Certainly inline (in my testing so far) with the previous (feedback adjusted) version of the FW. Even distanced vehicles at the edge of a 5442 FOV (i.e. not the central point of focus) have picked up very well, quicker in most cases and on point i.e. no 'false' vehicle categorization.​
However, there are some issues in SMD object detection. This unfortunately is not working 100% accurate. As you can see below, while Vehicle detection is great, 'Human' detection needs some work as evidenced by this Human.........Deer.​
SMD 3-0 Detecting A Deer As Human.jpg


5241 Testing

The 5241 saw the same issues as I mentioned above on the 5442 although depending on your FOV and use case (such as LPR etc) you may not find the Auto IR impacts as badly due to distance to target and inability to wash out based on that distance. Either way, I would recommend sticking with FW 11/23 or 12/03​
@wittaj I did check the issues you mentioned on the 5241-Z12 on a couple here and do not see those same problems. Specifically, do not see:​
  • Shifting of shutter settings you mentioned between SMD & IVS
  • Do not see delay in SMD detection across FOV (although as mentioned above, Human detection need work AI wise)
Therefore I would definitely recommend the 3-5 factory reset approach to see if that helps.​
You also mentioned iFrame which has indeed changed from the old 30-150 user input setting to only specifying at or double chosen FPS. Generally this should not be a problem for most since you want to look at matching your FPS with iFrame and in most cams you'll hit 30 fps or 60 fps (NTSC standards) depending on the model. Not to say that there aren't use cases for being able to utilize the user input but since the AI Codec option does scale with international standard too (again based on FPS) it does mean that even in PAL countries you are covered in matching at or double your chosen FPS (25/50 in the case of pal).​


Summary

So in summary, there are definitely under the hood code changes here, some working very well BUT there are others such as Human object detection and Auto IR that need to be adjusted by taking the 11/23 12/03 FW changes I covered and shared before and have them merged into this new FW.

I've detailed the code level changes that need to be targeted and made Dahua aware. @EMPIRETECANDY as always thanks for bringing this beta form of the FW for testing and for helping ensure Dahua understand the critical areas to fix, much appreciated !​


HTH
 

EMPIRETECANDY

IPCT Vendor
Joined
Nov 8, 2016
Messages
6,660
Reaction score
17,162
Location
HONGKONG
Thanks for guys testing, i collect the problems and send to dahua.
Mainly 2 big problems.

1. No Smart IR.
2. False recognition on cat/deer as people.

Solutions

DH will send me a new fw about solving the false alarms/recognitions.

So Next week we will get the SMD 3.0 with Smart IR.

Andy
 
Last edited:

genelit

Getting comfortable
Joined
Jan 4, 2018
Messages
263
Reaction score
391
Location
Sweden
Hi again,

Here's an update with "proof" where a Cat, Dog and Horse triggers IVS with SMD turned on.
On the Cat picture SMD sensitivity was set to High, for the Dog and Horse picture the sensitivity was on default Medium.

If you need further testing for Hens, Sheep or Pigs that can be arranged to, LOL! =) I bet you all would love to see me walking a pig in a leash! :lmao:

These alarms are Only with SMD in combination With tripwire and not MD/SMD alone.
I'll turn of IVS redo the tests.
 

Attachments

genelit

Getting comfortable
Joined
Jan 4, 2018
Messages
263
Reaction score
391
Location
Sweden
I believe they're independent of each other... so yeah test SMD not IVS
The notification i get from DMSS says MD and not Tripwire. Will be interesting to see what happens now IVS off.

@EMPIRETECANDY Yeah, it's April and freezing in Sweden! It was snowing yesterday! Only the cat can be "naked"
 

Attachments

Wildcat_1

Known around here
Joined
Dec 9, 2018
Messages
1,737
Reaction score
4,663
Location
US
All, as promised last night, here is a quick clip showing the difference between SMD 3.0 vs SMD 2.0 with regards to IR (Auto vs Smart) on a 5442 Vari Turret. Make sure to select minimum of HD although I did upload native res which will be available when YT finishes processing as 2K.

 

wittaj

IPCT Contributor
Joined
Apr 28, 2019
Messages
13,387
Reaction score
24,957
Location
USA
5241 Testing

The 5241 saw the same issues as I mentioned above on the 5442 although depending on your FOV and use case (such as LPR etc) you may not find the Auto IR impacts as badly due to distance to target and inability to wash out based on that distance. Either way, I would recommend sticking with FW 11/23 or 12/03​
@wittaj I did check the issues you mentioned on the 5241-Z12 on a couple here and do not see those same problems. Specifically, do not see:​

  • Shifting of shutter settings you mentioned between SMD & IVS
  • Do not see delay in SMD detection across FOV (although as mentioned above, Human detection need work AI wise)
Therefore I would definitely recommend the 3-5 factory reset approach to see if that helps.​
You also mentioned iFrame which has indeed changed from the old 30-150 user input setting to only specifying at or double chosen FPS. Generally this should not be a problem for most since you want to look at matching your FPS with iFrame and in most cams you'll hit 30 fps or 60 fps (NTSC standards) depending on the model. Not to say that there aren't use cases for being able to utilize the user input but since the AI Codec option does scale with international standard too (again based on FPS) it does mean that even in PAL countries you are covered in matching at or double your chosen FPS (25/50 in the case of pal).​
Sadly, a 5 time factory reset did not fix the changing of shutter and gain switching back and forth between SMD and IVS. I still experience the delay in SMD. I did this on my more recent 5241-Z12 though and the settings for the same location are completely different, so there could be differences in the hardware between an older 5241-Z12 and a newer 5241-Z12 that has a build date of October 2020. My other 5241-Z12 had a build date of October 2019.
 

Wildcat_1

Known around here
Joined
Dec 9, 2018
Messages
1,737
Reaction score
4,663
Location
US
Sadly, a 5 time factory reset did not fix the changing of shutter and gain switching back and forth between SMD and IVS. I still experience the delay in SMD. I did this on my more recent 5241-Z12 though and the settings for the same location are completely different, so there could be differences in the hardware between an older 5241-Z12 and a newer 5241-Z12 that has a build date of October 2020. My other 5241-Z12 had a build date of October 2019.
Yes could be HW revision playing a role for sure. Tried on 3 x 5241-Z12s and do not see these issues but like I said I would also advise people stick with 11/23 or 12/03 until this FW gets fixed for IR and Human AI detection anyway.
 

Wildcat_1

Known around here
Joined
Dec 9, 2018
Messages
1,737
Reaction score
4,663
Location
US
My 5442 NI bullet didn’t like it. Now asking for a plug-in in IE which won’t load. No way to access stream on the camera. Tried other browsers. Brand new camera too..
@bigredfish couple of things:

1) Did it prompt you to download the new webplugin ? There is a new one associated with the update that should prompt you after upgrade.​
2) Firefox won’t let you see the UI and stream ?​
3) Did you try accessing the stream via RTSP for now using - rtsp:/<Username>:<Password>@<IP Address>:554/cam/realmonitor?channel=1&subtype=0​

Not sure if you already knew about this next one or not so if you did just forget it but others might find it useful too:

4) Lastly, if you do want to force the camera(s) to re-prompt for webplugin you can delete the webrec folder on your computer. Located in 2 locations C:\Program Files\webrec and C:\Program Files (x86)\webrec. Just remember that if you do nuke the webrec folder that you will be prompted to install the webplugin.exe for all cams you access after in IE as it will be seen as the first time again.​

HTH, if still no joy let me know and I'll see if I can assist further
 
Last edited:

genelit

Getting comfortable
Joined
Jan 4, 2018
Messages
263
Reaction score
391
Location
Sweden
Hi,

I have been testing SMD 3.0 now with IVS turned off and I have less false positives. It is still not 100% as I got a SMD Human Alert from a Hen, SMD settings are back to Medium sensitivity.
But, it works much better than in combination with IVS.
Further I can also confirm that I get a correct SMD Human Alerts with a T5442T-ZE (fully zoomed in) at the range of 30m/~90ft.

Hen capture - human.PNG

Edit: The cat triggered SMD Human again, even with tripwire of.
 
Last edited:

bigredfish

Known around here
Joined
Sep 5, 2016
Messages
11,100
Reaction score
28,451
Location
Florida USA
@bigredfish couple of things:

1) Did it prompt you to download the new webplugin ? There is a new one associated with the update that should prompt you after upgrade.​
2) Firefox won’t let you see the UI and stream ?​
3) Did you try accessing the stream via RTSP for now using - rtsp:/<Username>:<Password>@<IP Address>:554/cam/realmonitor?channel=1&subtype=0​

Not sure if you already knew about this next one or not so if you did just forget it but others might find it useful too:

4) Lastly, if you do want to force the camera(s) to re-prompt for webplugin you can delete the webrec folder on your computer. Located in 2 locations C:\Program Files\webrec and C:\Program Files (x86)\webrec. Just remember that if you do nuke the webrec folder that you will be prompted to install the webplugin.exe for all cams you access after in IE as it will be seen as the first time again.​

HTH, if still no joy let me know and I'll see if I can assist further

Yep prompted for the new plugin
Nope Firefox, nor Pale Moon nor IE can get a stream
SmartPSS is still pulling the stream (old version)
Plug-in fails
595209D9-173C-4EDE-9876-3DA4E25BCD66.jpeg
 
Last edited:
Top