5.2.8 - May 20, 2020 - Direct-to-disc BVR recording will now include metadata for video overlays

fenderman

Staff member
Joined
Mar 9, 2014
Messages
33,237
Reaction score
12,114
5.2.8 - May 20, 2020
Direct-to-disc BVR recording will now include metadata for video overlays (bitmaps and
text), motion detection rectangles, as well as camera state flags (such as DIO input bits,
motion sensing and triggered state).
When a BVR file containing these new metadata is opened in the viewer, you may right-click
and select from menu options to toggle their display.
 

area651

Getting comfortable
Joined
Aug 18, 2018
Messages
401
Reaction score
311
Location
USA
Now this is very awesome! I just tested it and now I want to run "Trigger Tab>Motion Sensor Configure button>Highlight:Show object rectangles" on all my cameras so I can filter that on/off while watching them later. Sometimes I get an alert and I'm not sure where it came from. This is a great change imho.

Does anyone know of quick way (hotkey maybe?) to turn off/on the rectangles showing during live view? If not, I'll live with it to get the opportunity to turn it on/off when reviewing.
 

bp2008

Staff member
Joined
Mar 10, 2014
Messages
9,941
Reaction score
7,449
Location
USA
Does anyone know of quick way (hotkey maybe?) to turn off/on the rectangles showing during live view? If not, I'll live with it to get the opportunity to turn it on/off when reviewing.
You can change motion highlighting in camera properties in UI3 and I'm pretty sure it doesn't even require the camera to restart. But I'm not aware of a quick way in the BI local console.
 

Tinman

Getting comfortable
Joined
Nov 2, 2015
Messages
723
Reaction score
542
So does this mean we no longer need net time and use the camera's time now ?

Edit: just tried it and it works !
 
Last edited:

DarkHelmet

Getting the hang of it
Joined
Feb 26, 2017
Messages
126
Reaction score
40
moving my post from other thread:

i think Ken and I must be on the same wavelength. I emailed him 3 days ago about overlay metadata being saved and BOOM, 5.2.8.0. Dude is awesome. Now to figure out how it works...

edit: there are now "add motion overlays..." and "add text/graphic overlays" options in the right click menu when viewing clips. There is also a misspelled "Include ovleray" option that doesn't seem to do anything. (ken emailed)
edit2: export window has changed from using "current" overlays to using saved BVR overlays.
edit3: overlays now show when soloing a camera and viewing main-stream.
edit4: overlays may not initially show during recordings after the update. you have to wait until the clip splits into a new clip, then they show.
 
Last edited:

IAmATeaf

Known around here
Joined
Jan 13, 2019
Messages
1,091
Reaction score
573
Location
United Kingdom
Now this is very awesome! I just tested it and now I want to run "Trigger Tab>Motion Sensor Configure button>Highlight:Show object rectangles" on all my cameras so I can filter that on/off while watching them later. Sometimes I get an alert and I'm not sure where it came from. This is a great change imho.

Does anyone know of quick way (hotkey maybe?) to turn off/on the rectangles showing during live view? If not, I'll live with it to get the opportunity to turn it on/off when reviewing.
Hasn’t this always been there? Seem to recall using it ages back to fine tune my motion detection settings.
 

105437

BIT Beta Team
Joined
Jun 8, 2015
Messages
840
Reaction score
151
I'm running 5.2.8 and I see object rectangles when playing back alerts. I don't have "Show object rectangles" selected in the Trigger tab for each camera. Where else is this set so I can turn it off? This started happening as soon as I upgraded. Not a huge deal, just testing the new release before I can roll back. Thanks
 

beepsilver

Getting comfortable
Joined
Mar 9, 2014
Messages
621
Reaction score
328
Location
Nebraska
I'm running 5.2.8 and I see object rectangles when playing back alerts. I don't have "Show object rectangles" selected in the Trigger tab for each camera. Where else is this set so I can turn it off? This started happening as soon as I upgraded. Not a huge deal, just testing the new release before I can roll back. Thanks
During playback on your alert video window, right click and turn off 'Test run video through motion detector.'
 

Tinman

Getting comfortable
Joined
Nov 2, 2015
Messages
723
Reaction score
542
My motion highlight squares seem to appear sometimes in UI3 and then if I play the clip again they don't. I also see this on the Iphone app. I do not have it checked in BI. I also found that if you don't have "object detection" checked in cams motion setup, you won't see the motion squares.
 

Tinman

Getting comfortable
Joined
Nov 2, 2015
Messages
723
Reaction score
542
I'm also started getting this weird 49 day crap too ??

Annotation 2020-05-21 094125.jpg
 

kklee

n3wb
Joined
May 9, 2020
Messages
21
Reaction score
21
Location
Vancouver, BC
Continuing on in this thread regarding the problem I had with 5.2.8.0 being unstable. It was crashing on start and I rolled back to 5.2.7.12.

Hopefully this helps with anybody else running into this issue.

I narrowed down the problem to be related to recording as MP4 files.

I have 5 cameras configured as motion trigger to BVR files and 4 of those 5 have a cloned copy that record continuously as MP4 files.

I disabled all cameras and updated to 5.2.8.0 which ran fine. Then I started enabling cameras.

I found that enabling any of the continuous recording cameras caused an instant crash.

The main configuration difference between the continuous and motion trigger cameras is file format.

I reconfigured the continuous recording cameras to use BVR and now 5.2.8.0 is stable.

I've traded emails with Ken about this, so hopefully he'll have a fix for it.
 

area651

Getting comfortable
Joined
Aug 18, 2018
Messages
401
Reaction score
311
Location
USA
Hasn’t this always been there? Seem to recall using it ages back to fine tune my motion detection settings.
I think the rectangles highlight has always been there but if you didnt have them highlighting during the live view (or when it happened), then I dont think we had the option to enable them upon later playback. I'm no expert and could be wrong though.
 

Tinman

Getting comfortable
Joined
Nov 2, 2015
Messages
723
Reaction score
542
I've noticed the same problem with 49 day video clips which record short periods. I'm currently reverting cameras back to working without sub streams to see if that corrects the issue.
Mine went away when I restarted BI. But keep a eye on it, mine go away and then will show up again for no reason.
 
Joined
Dec 28, 2019
Messages
723
Reaction score
776
Location
New Jersey
Anyone else seeing "artifact" motion rectangles both on the console and in UI3? I have a 5442 turret and it has a bunch of rectangles left over from shadow motion earlier in the day. It does display the current motion accurately but these artifacts don't seem to want to go away. That camera also crashed the console if I try playing back a clip. It's running CBR, 8192bps, @15fps on the mainstream and 1096bps@15fps, CBR on the substream. I frames are both set at 15.
 

tward392

Young grasshopper
Joined
Sep 9, 2019
Messages
48
Reaction score
11
Location
US
I had one camera last night that keep one of the yellow rectangles in the live camera view. It was after I blacked out an area in the motion sensor stuff to stop getting alerts from a certain area, so I thought it had something to do with that.

I had to stop the service and restart it before it disappeared. It only showed in the live view not in any other alerts or the clip. 5.2.8.0 is still a little buggy I guess, no show stoppers though.

I have almost all of the recent versions crashing when playing back clips, but usually turning off the "Test run video through motion detector" usually stops the crashing.
 

tward392

Young grasshopper
Joined
Sep 9, 2019
Messages
48
Reaction score
11
Location
US
Have also been noticing some "Clip: write error 80000456, undefined" errors lately. Not sure when those started.
 
Top