Blue Iris UI3

Discussion in 'Blue Iris' started by bp2008, Nov 1, 2017.

Share This Page

  1. Ssayer

    Ssayer Pulling my weight

    Joined:
    Jan 5, 2016
    Messages:
    369
    Likes Received:
    162
    Location:
    SE Michigan USA
    Hah! Sometimes the hardest part of this stuff is figuring out the right question to ask and the right place to ask it, eh? I have to believe that you're correct on the hardware acceleration drivers.
     
    bp2008 and TL1096r like this.
  2. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
    You described me when I try to troubleshoot. :) What did you purchase to make all that work? I was thinking about getting rid of one of my windows 10 sticks for a Pi.
     
  3. Ssayer

    Ssayer Pulling my weight

    Joined:
    Jan 5, 2016
    Messages:
    369
    Likes Received:
    162
    Location:
    SE Michigan USA
    I bought this for my 3D Printer last September, but decided I liked using the printer's interface better, so it's been sitting waiting for a use:

    https://www.amazon.com/gp/product/B01C6Q2GSY

    Aside from that? A keyboard, mouse, and monitor with HD port. I just went out and looked. That's it...

    Needed OS is here:
    Download Raspbian for Raspberry Pi

    and I used Etcher to put it on the MicroSD card:
    balenaEtcher - Home

    DON'T waste your time with the OS on the included MicroSD card. Just put Raspbian on it and it's all good.
     
    SouthernYankee and TL1096r like this.
  4. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
    Oh nice. I have that same one in my amazon cart already. I have that software downloaded as I heard it was more user friendly. And I used balenaEtcher to load sophos on USB before and it was fairly easy. I feel a bit confident in this and maybe that is a good sign. Thanks for your links and time.
     
    Ssayer likes this.
  5. Ssayer

    Ssayer Pulling my weight

    Joined:
    Jan 5, 2016
    Messages:
    369
    Likes Received:
    162
    Location:
    SE Michigan USA
    Any time. I doubt you'll need any help, as this is pretty straight forward. But if you do, please feel free to say something!
     
    TL1096r likes this.
  6. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
  7. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,764
    Likes Received:
    5,840
    Good choice. I forgot there was a + version of the pi 3. I was reading the other day there isn't likely to be a new faster pi for quite a while because they need to use a more advanced manufacturing process to get really any better. Pi is built with a 40nm process that is rather aged now, for reasons of the low level I/O it uses, apparently they can't just stick a more modern CPU in it without a lot of work.
     
    TL1096r likes this.
  8. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
    Yes it seems like a better choice.

    I might look into installing openvpn in mine:
    PiVPN: Simplest setup of OpenVPN

    I am wondering is it a good idea to also install pihole? That seems to more have ads removed and works with pivpn but not necessary if I read this correctly:
    Pi-holeĀ®: A black hole for Internet advertisements

    I just want to say thanks for all the great products you put out there and your attention to replies. It is appreciated. I have a question.. Is there a limit of how many systems can be running UI3 at the same time? Will it cause any issues?

    And with pi3 does UI3 work ok with it or do you suggest what you created here:
    bp2008/OmxPlayerAuto

    Thank you
     
  9. cferd5

    cferd5 n3wb

    Joined:
    Aug 6, 2017
    Messages:
    19
    Likes Received:
    6
    This is one humongous thread. Maybe UI3 should have it's own sub-forum?
     
    aesterling, TL1096r and handinpalm like this.
  10. cagenuts

    cagenuts n3wb

    Joined:
    Oct 30, 2017
    Messages:
    9
    Likes Received:
    2
    Location:
    Johannesburg South Africa
    UI3 works like a bomb on my Pi3s. I have four running like this and sometimes I think the wireless is lagging so I'm going to run some Ethernet cables. Bog standard Raspbian with the stock browser. You just have to to install the xscreensaver (and then disable) it to stop the video going to sleep.
     
    TL1096r likes this.
  11. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
    Great info. Thanks for sharing. You can run 4 at the same time without any video issues?

    Can you just use chromium that is default with Raspbian?
     
  12. cagenuts

    cagenuts n3wb

    Joined:
    Oct 30, 2017
    Messages:
    9
    Likes Received:
    2
    Location:
    Johannesburg South Africa
    I have four Pi3s each with their own monitor scattered around the house. I just use Chromium that is preloaded. I initially tried with a Pi Zero but the little Wireless chip just couldn't handle more than one camera.
     
    TL1096r likes this.
  13. lb88

    lb88 n3wb

    Joined:
    Feb 25, 2018
    Messages:
    15
    Likes Received:
    3
    Latest blue iris 5.0.0.50 ui3 is glitching out after login tried locally and remotely. I ended up copying the UI3-77 files from github to the www folder which i believe are supposed to be the same files for the 5.0.0.50 release, regardless it fixed the issue.

    [​IMG]
     
    bigcheze likes this.
  14. R4nger

    R4nger n3wb

    Joined:
    Oct 28, 2018
    Messages:
    10
    Likes Received:
    1
    Location:
    England
    This has happened to me also.
     
  15. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,764
    Likes Received:
    5,840
    BI 5.0.0.50 isn't installing UI3 correctly. It in fact deletes the ui3 subfolder outright, which is a big deal for anyone who may have installed a local-overrides file since it would be gone after updating!
     
  16. bigcheze

    bigcheze n3wb

    Joined:
    Jun 9, 2019
    Messages:
    1
    Likes Received:
    0
    Location:
    TX
    I ran into this as well and the github fix also resolved it for me.
    For those unfamiliar with git hub and where to look, to save you some time figuring things out,
    1) The UI3-77 files can be downloaded from https://github.com/bp2008/ui3/releases/download/77/UI3-77.zip
    2) Extract the zip file to a directory and rename the directory to www.
    3) Browse to C:\Program Files\Blue Iris 5
    4) Rename the www folder to www.old
    5) Copy the www folder with the new files into the Blue Iris 5 directory

    You should now be able to access the web interface again.
    If everything is working you can also delete the www.old folder.
     
  17. social26

    social26 n3wb

    Joined:
    Jun 9, 2019
    Messages:
    10
    Likes Received:
    0
    Location:
    LA
    The same problem here after upgraded to .50 also downloaded UI3-77 and unzipped it to another folder then pointed the www root to it, reboot it fixed it.
     
  18. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,764
    Likes Received:
    5,840
    I would not recommend installing UI3 outside of the www folder and pointing the web server at it. Best to install in the default place.
     
  19. social26

    social26 n3wb

    Joined:
    Jun 9, 2019
    Messages:
    10
    Likes Received:
    0
    Location:
    LA
    Just found .51 is available, it might fix the UI3 problem, will try to point www back to default place after .51

    ps: No, UI3 still broken in .51
     
  20. TL1096r

    TL1096r Pulling my weight

    Joined:
    Jan 28, 2017
    Messages:
    695
    Likes Received:
    146
    Thanks. Very easy to setup xscreensaver and have IU3 up and running on pi3 b+. It is much better than w10 stick.