Hardware acceleration cause of ghosting?

Discussion in 'Blue Iris' started by zlandar, Jul 29, 2018.

Share This Page

  1. zlandar

    zlandar n3wb

    Joined:
    May 11, 2015
    Messages:
    16
    Likes Received:
    2
    I've used BI for several years and noticed ghosting (pixelation of a moving object in a recording) that occurs more frequently at higher resolutions.

    My last attempted fix was to switch from .264 to .265 on my 8 MP cams (2CD2085FWD). Looked at half a dozen recordings and no ghosting. Hardware acceleration is disabled in .265 as BI doesn't currently support it.

    Then I decided to switch back to .264 and turn off hardware acceleration for all cams. No ghosting.

    Is hardware acceleration to blame for the ghosting issues? Seems like it to me. Hardware I'm using below:

    Server- 8700k with 16GB RAM using onboard Intel video. Mix of five 4/8 GB hard drives directly connected to the motherboard using Stablebit Drivepool to manage them.

    6 Hikvision cams, three 8 MP, two 4MP, and a 3 MP. All running at max resolution and fps. Connection is either through bonded MOCA adapter (80 MB/sec transfer) or WiFi 5GHz bridge to server (link rate 100 MB/sec).

    Main router sits next to server which is an ASUS GT-AC5300 which receives streams either through WiFi or bonded MOCA adapter. Router is connected to the server with dual 1 GB ethernet using 802.3ad link aggregation.

    Cam receive buffer at 20 MB, I interval matches FPS. These didn't help ghosting much IMO.
     
  2. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    28,359
    Likes Received:
    8,058
    what exact version of BI are you using? post a video of the ghosting.
    HA is not the cause of ghosting or everyone would be seeing it. Connect a camera via ethernet and see if you have the same issue.
     
  3. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    7,852
    Likes Received:
    4,568
    Make sure the "Max rate" setting in Blue Iris camera properties, video tab, is higher than the FPS of the cameras. If the cameras are 15 FPS then maybe set BI's max rate to 17 FPS or higher. Higher values here do result in higher memory usage, and it is supposed to auto-adjust, but it doesn't always work 100% perfectly.
     
  4. zlandar

    zlandar n3wb

    Joined:
    May 11, 2015
    Messages:
    16
    Likes Received:
    2
    Ghosting example:


    I'm on BI version 4.7.6.11.

    Oddly the ghosting was not present on the exported clip I obtained through the UI3 browser even though it's visible when I view the clip through UI3 and on the BI console. I had to export the clip through the BI console.

    The ghosting doesn't always happen. I would guesstimate 20% of the time with the 8 MP cams. Enough to be annoying.

    BI has FPS equal or higher the values set on the Hikvision cams.
     
  5. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    28,359
    Likes Received:
    8,058
    in the camera properties > video> uncheck also bvr
     
  6. zlandar

    zlandar n3wb

    Joined:
    May 11, 2015
    Messages:
    16
    Likes Received:
    2
    I've unchecked BVR for all the cams, turned HA acceleration back on, and rebooted the server. I'll check the recorded video in a couple hours to get a decent sample size and see if the ghosting recurs.

    Why would BVR being turned on cause the ghosting? I think the default is for BVR to be checked.

    Edit: Already had two video recordings with the same ghosting. Turning HA off.
     
    Last edited: Jul 29, 2018
  7. Terk

    Terk Pulling my weight

    Joined:
    Feb 14, 2018
    Messages:
    249
    Likes Received:
    105
  8. zlandar

    zlandar n3wb

    Joined:
    May 11, 2015
    Messages:
    16
    Likes Received:
    2
    That's the same graphics glitch I have. Besides the smearing/pixelation there is also a herky-jerky quality to the recorded videos that is not present when HA is turned off.

    Looking at the BI wiki the authors are concerned about a memory leak and don't mention the graphical glitch:

    Memory Leak: Quick Sync (Hardware Acceleration) | IP Cam Talk

    I am using the same driver version as posted on the wiki 24.20.100.6194. That's the one the Intel update utility selected on my PC.

    I might try reverting to an older driver and see if the glitch resolves. Without HA enabled BI takes up 20% of the CPU vs 10% with HA on.
     
  9. kcorbin

    kcorbin n3wb

    Joined:
    Nov 7, 2018
    Messages:
    1
    Likes Received:
    0
    Location:
    Mars, PA
    I'm having the same issue with ghosting in recordings that appears to be caused by hardware acceleration and the intel driver. System is Win10 Pro, i7 8700k, 32GB RAM. Currently only 3 cameras, IPC-HDW5231R-ZE, at 15fps, recording direct to disk. I'm running BI 4.8.3.0 and had Intel driver 24.20.100.6195 installed initially. Went through all of the other recommendations with iframe aligned to fps, increased buffer, etc and the ghosting remained. I updated to the latest driver released a few days ago.. 25.20.100.6373 and still no improvement. Turning off hardware acceleration eliminates the ghosting from the recordings. With the limited number of cameras (for now), the CPU impact with HA on vs off is negligible at <10% either way, though I plan to add more cameras. Are there any known drivers for the i7 8700k that do not have memory leaks OR ghosting? Any other thoughts on what to try? Thanks!
     
  10. SAVideoman

    SAVideoman Getting the hang of it

    Joined:
    May 20, 2016
    Messages:
    39
    Likes Received:
    48
    The "ghosting" you're seeing is actually dropped frames. Somewhere along the line some process isn't keeping up with the number of frames coming in from the camera or from the disc. Could be at the decoder or possibly your drive isn't keeping up with frames being recorded. BI status may show some hints about the dropped frames. You may need to lower the frame rate of your cameras.
     
    bigredfish likes this.
  11. Braap

    Braap n3wb

    Joined:
    Jan 30, 2019
    Messages:
    2
    Likes Received:
    0
    Location:
    U.S.A.
    I'm experiencing the same ghosting when hardware acceleration is turned on. As soon as I turn off HA, the ghosting is gone. I've also rolled back my driver to the recommendation on the wiki page (24.20.100.6194), aligned iframe to fps, etc. I'm running 6 cameras, Blue Irirs release 4.8.4.7, running Windows 10 Pro with i5 8400.

    Has anyone found a solution yet?
     
  12. Walrus

    Walrus Getting the hang of it

    Joined:
    Nov 19, 2018
    Messages:
    71
    Likes Received:
    33
    Location:
    Ontario
    I had the same thing a few weeks ago, and setting the i-frame interval to match the FPS fixed it for me.
     
  13. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    28,359
    Likes Received:
    8,058
    ensure you are not using a smart codec or h264+ also follow the directions above with respect to also bvr.
     
  14. Braap

    Braap n3wb

    Joined:
    Jan 30, 2019
    Messages:
    2
    Likes Received:
    0
    Location:
    U.S.A.
    My Dahua cameras are set as follows:
    Encode Mode = H.264H (the only other option is H.265)
    Smart Codec = OFF

    The Hikvisions are:
    Video Encoding = H.264
    H.264+ = OFF

    In Blue Iris, "Also BVR" is unchecked for all cameras.
     
  15. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    28,359
    Likes Received:
    8,058
    I would try a different video driver.
     
  16. jimmyb

    jimmyb n3wb

    Joined:
    Mar 19, 2018
    Messages:
    1
    Likes Received:
    0
    I've experienced the same issue with every 8th gen Intel build I've done, even after testing with few cameras and low FPS. I've tried countless drivers.

    Following best practices like matching the i-frame rate to FPS, matching FPS on camera and in BI, excluding BI storage from antivirus scans, using direct-to-disk, etc... may cause the ghosting to happen less frequently, but not solve the problem.

    Turning off hardware acceleration in BI immediately and consistently stops the ghosting. It's the only thing that's worked for me.

    Therefore, the best compromise for me was to turn off hardware acceleration in BI, switch to H.265 on the cameras, and deal with slightly higher CPU usage on all of our Intel 8th gen builds.

    Since HA has been frustratingly useless in the newer generation of Intel processors, my next build is either going back to an older model Intel, or using a Ryzen with all H.265.
     
  17. SevenPointSupp

    SevenPointSupp n3wb

    Joined:
    Aug 3, 2018
    Messages:
    1
    Likes Received:
    2
    Location:
    Pinole
    I had the same issue and installing older video driver 21.20.16.4664 worked for me.
     
    fenderman and Walrus like this.