Hikvision DS7604NI-E1 bricked. HELP!

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
Hello, it seems I download the wrong firmware to update my NVR. Now I am stuck in a bootlop. I boot till startscreen, then start to BEEP for 10s and restart. I tried to connect via tftp, but the NVR is not connecting. I set my PC to 192.0.0.128 and connected the PC and NVR over Router, also I turned DHCP off. I get response when I ping 192.0.0.64. But tftp server show no connection.

What else can I do to repair the NVR?
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
12,850
Reaction score
4,342
Location
Scotland
But tftp server show no connection.
Are you using the Hikvision-specific tftp server, that they no longer publish, but is available (along with instructions) in the first download link here :
Custom Firmware Downgrader 5.3.0 Chinese to 5.2.5 English
Also check that the Windows firewall is allowing inbound connections to your PC from tftpserve.exe
If that does not work, the next method will be using the serial console connection to flash the right firmware.
Some info here - NVRs and cameras have the same connections : Hikvision Camera Dead No POE - But Green & Red Lights On
Check out the whole thread.
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
Firewall is off. I am using the HikVision TFTP Server. It's strange that I can ping the NVR till restart, but get no connection with TFTP. I read the whole tread, but I am not quite sure how to connect over Serial Console properly. Do you have some more informations?
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
12,850
Reaction score
4,342
Location
Scotland
I am not quite sure how to connect over Serial Console properly. Do you have some more informations?
Assuming the 7604 has the same serial console connector as the 7608 and the Hikvision cameras, you need a couple of pieces of hardware:
A USB to TTL serial convertor. Very common are those based on the Prolific PL2303HX chip - search your favourite on-line store for a local source. Those with wires are easier to use than with pins.
A Micro ZH 1.5mm 4-Pin JST Connector with Wires. Local sources for these may be harder to find, but this 3-pin one was found to work OK :
Hikvision Camera Dead No POE - But Green & Red Lights On
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
Thank you for your reply. I will get the hardware tomorrow so I give it a try.
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
I dont' get anything on Putty. Set to 115200, 8N1, COM8. Is the NVR definitly bricked? Because its stucked in a bootlop, I thought it can be fixed.
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
I got a connection over Putty and updated the firmware over TFTP. First I have to use hiktools to set language to "2" because I get a language mismatch first time. Everything went fine, I hit Enter to reboot and now I'm getting this. Somebody a idea what to do?
 

Attachments

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
12,850
Reaction score
4,342
Location
Scotland
A couple of things - with PuTTY you can copy the text of a session to the clipboard, the top left menu. Insert as CODE, easier to read than a picture.
On the error - that is what results when non-Chinese region firmware (and I don't mean the header language that Hiktools can alter) is applied to a CN region NVR. Does it also say '!!!You bought in CN!!!'?
Though you have stated that the NVR is DS7604NI-E1 which should be 'International'.
What firmware did you originally load that caused the bootloop?
What firmware did you load via the serial console also that caused the bootloop?
If it was from the US site, try this : HIKVISION EUROPE
And if that still gives a bootloop, try the third one down here, for 7804N 海康威视——以视频为核心的物联网解决方案和数据运营服务提供商
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
Sorry, didn't thought about before. I know for the next time, thanks.

It don't say !!!You bought in CN!!!, just the !!!you device is illegal, please call factory!!!. But yes, the NVR is bought over alibaba, from China. I tried US and EU Versions, but the result is the same. First I updated the US version over USB, that caused the bootlop. After that I tried EU and USA over Serial Console. I will try the 3rd one now. What language will it be if success?
 

Srbo

n3wb
Joined
Nov 15, 2016
Messages
8
Reaction score
0
Ok, it worked. The NVR is booting, but the language is Chinese. How I can set it to English?
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
12,850
Reaction score
4,342
Location
Scotland
Well, as you do seem quite gung-ho and adventurous, and have already used the serial console, check your conversations ...
 

Playbox

n3wb
Joined
Sep 18, 2016
Messages
23
Reaction score
1
Location
Australia
Hi All,
Great forum ,
been doing some reading ...I have a NVR that's in boot loop also , tried TFTP no luck.

Just ordered a USB to TTL serial & 4 pin JST ,

The NVR DS-7608N , AARR in serial.

Will give it a try with Putty ,

Cheers ...
 

Playbox

n3wb
Joined
Sep 18, 2016
Messages
23
Reaction score
1
Location
Australia
But been thinking Im going to try tftp from a couple of different PC's just in case PC & OS ver is causing a problem.
 

alastairstevenson

Staff member
Joined
Oct 28, 2014
Messages
12,850
Reaction score
4,342
Location
Scotland
Updated firmware, tftp will not connect ...as the unit beeps 15 times then reboots ..boot loop
On the serial console it will be complaining "!!! You bought in China!!! !!! You device is illegal !!!"
So it's a CN region NVR with EN firmware.
I have firmware that will fix that. I'm away just now, back tomorrow.
 

Playbox

n3wb
Joined
Sep 18, 2016
Messages
23
Reaction score
1
Location
Australia
Thanks for that..
So I would only be able to recover via the serial console, with the correct firmware.... ?
 

bixpii

n3wb
Joined
Feb 14, 2020
Messages
11
Reaction score
1
Location
hai duong
On the serial console it will be complaining "!!! You bought in China!!! !!! You device is illegal !!!"
So it's a CN region NVR with EN firmware.
I have firmware that will fix that. I'm away just now, back tomorrow.
Hello, i still using DS-7604N-E1/4P with Chinese firmware. I can't get English firmware for it. I had tried hiktools to set language of NVR_K41_BL_ML_STD_V3.4.80_160718 firmware from 1 to 2. It fixed language misstake but get error :
!!!!!!!you Device is illegal, Please call factory!!!!!!
!!!!!!!you Device buy in cn, you firmware is en err!!!!!!

So how can i upgrade to English firmware or can you share me any firmware have English?
Thankyou so much!
PS: If i upgrade NVR_K41_QD_CN_STD_V3.4.106_191009 from chinese site it only have chinese
 
Top