IP Cam Talk

Welcome to the new IPCT! If you are having an issue logging in, please clear your cookies / cache.

Hikvision FIRMWARE TOOLS - change language, extract files and create own firmware

Defender666

Getting the hang of it
Actually I just need the Cloud key for this camera. The Webif does not show it on this firmware version.
 

KenK73

n3wb
Wow... what kind of fresh hell have I stepped into?

I have a pair of old DS-2CD2532F-IS cameras that have been running un-modified since purchase. I just picked up another one off eBay along with a DS-2CD2542FWD-IS to add to my coverage. I check Hikvision out of curiosity to see if there is new firmware. There is, so I grab it.

The updates on the 2 new cameras goes pretty well. The two old cameras get bricked. After much research, I find this forum and get the 2 older cameras back on-line with the v5.2.5 downgrade (THANK YOU!).

So now I am confused as to what my upgrade options are for the older cameras. The new ones are "WR" thankfully, but the older ones are both:

Serial NO :DS-2CD2532F-IS20150204CCCH50318xxxx
V5.2.5 build 141201
hardwareVersion = 0x0
hardWareExtVersion = 0x0
language = 1
devType = 38932

The v5.4.5 firmware for the DS-2CD2532F-IS looks quite nice and I would love to be able to run this on my older cameras. Is that a bridge too far? Does anything permanently fix this issue short of buying new "WR" cameras?

I am confused as to what the point is of running the MTD hacks? Will they let me install Chinese firmware and make the menus English? So I could install the CN v5.4.5?

And this Firmware tool, is it used in leu of the MTD hack or in concert with? Or not at all?
 

alastairstevenson

Staff member

KenK73

n3wb
Your patience is seemingly limitless, Mr. Alastair. Thanks for all your efforts.

I am reading the instructions for the brick-fix and I'm not sure thats where I need to be. I have already un-bricked my cameras using the "Raptor_2_520_f_10_14_c.dav" file. Both cameras, which had the EN 5.4.41 update applied and were bricked, are now back in service on Raptor 5.2.5 with EN menus.

I have the EN 5.4.5 update package that I downloaded from hikvision USA. My goal is to get both of these CN cameras on version 5.4.5. According to the document in this EN 5.4.5 package, I need to update to v5.4.41 first (included in 5.4.5 package) and then update to v5.4.5.

So at this point, with un-bricked cameras running Raptor 5.2.5, I believe the next steps are:

1. Copy the MTDBlock5/6 files off both cameras
2. Hex Edit the each file to change them to english and fix the checksum
3. Copy the MTD files back on to each camera
4. Reboot
5. Apply the v5.4.41 EN update to each camera
6. Reboot
7. Apply the EN v5.4.5 update to each camera
8. Reboot
9. Done!

Am I on track?
 

alastairstevenson

Staff member
Just another couple of things - check that the devType value doesn't have FF98 in it, if so check the output of the shell command prtHardInfo for the decimal value, to convert to hex.
And just in case there was originally 5.2.8 firmware, check locations 0x0C and 0x8000C in mtdblock1 and if they are 0 change then to 2.

Hikvision recommend not skipping major versions on updates.
 

KenK73

n3wb
In the shell, both report devType = 38932 (Hex: 9814 or 1498 in proper byte order)

The sticker on the back does show v5.2.8 so I will assume thats what was the hacked version there before my initial 5.4.41 update. I will check MTD1.

Here's what the firmware package had to say about updates:

"If the version falls into the range from V5.2.0 build 140721 to V5.4.0 Build 160530, you need a 2-step upgrade process. Note, if the step was skipped, your device may fail to operate normally.

1) update to V5.4.41 build 170310 FIRST, reboot
2) update to v5.4.5 Build 170123, reboot"

Since I am already at v5.2.5 I can't imagine I am skipping anything they haven't considered.
 

KenK73

n3wb
Well... not fully there yet.

I modified Block1, and 5 per your recommendations. When it came to Block6 I was confused by the checksum, so I followed steps 12-15 in MarkB's post in the DS-2CD2x32-I thread. I put in the correct hex for my dev type (14 98) and then put in the checksum for 09-FC in offsets 04 and 05. I did not modify 0x48 like in the video.

After I copied the updated Blocks 1, 5, and 6 to the device, it rebooted and came up fine on 5.2.5. So I went to the web guy and uploaded EN v5.4.41 and it rebooted, but no web GUI when it came back. I can still SSH into it on its proper camera IP (not the 192.0.0.64), but it obviously does me no good.

What did I miss?Attempt1.jpg
 

alastairstevenson

Staff member
Your mtdblock1 and mtdblock6 mods look OK, that should work just fine.
You can see in mtdblock1 that the camera was manufactured with 5.2.8 firmware, so this change was definiely needed.

mtdblock5 has been changed in an area unrelated to the hardware signature block. I don't know what that would do.
mtdblock5 needs no changes for the 'enhanced mtd hack' - it would be best to return the original to the camera.

So I went to the web guy and uploaded EN v5.4.41 and it rebooted, but no web GUI when it came back. I can still SSH into it on its proper camera IP (not the 192.0.0.64), but it obviously does me no good.
What does SADP show for the status and firmware version eg is that 4.0.8?
If so, that's in the min-system recovery state.

I'm speculating that if the problem isn't due to the change in mtdblock5 it may be caused by skipping all the intermediate firmware steps.
If you did the 'brick-fix' then you will be able to simply use the tftp updater to get back to 5.2.5 with the '5.3.0 to 5.2.5 downgrader' and proceed again from there.
 

KenK73

n3wb
Yes, I am already back to v5.2.5_raptor and everything works again. When it bricks, it does go back to 4.0.8 in SADP. I will put the original MTD5 back on.

So do I need to find an EN v5.3.0, v5.4.0, and load those first before trying the v5.4.41 and v5.4.5?
 

KenK73

n3wb
I must be unlucky...

I copied the original MTD5 back on and re-tried 5.4.41 again just to see if that was it. Nope! Back to the mini-system.

So I go back to v5.2.5_raptor, get things working, then try v5.3.0 from your link. Nope! Back to the mini-system.

So now I am back at v5.2.5_raptor and working again. Not sure what my options are at this point.

I don't need to re-install the MTD1/MTD6 each time I roll back to v5.2.5 do I?
 

alastairstevenson

Staff member
I don't need to re-install the MTD1/MTD6 each time I roll back to v5.2.5 do I?
No, the changes you made in mtdblock6 will persist. mtdblock1 gets re-written on an update.
So now I am back at v5.2.5_raptor and working again. Not sure what my options are at this point.
By all that you've shown, the upgrade should work OK.
As a long shot - you are starting at a different point from usual with this "v5.2.5_raptor" firmware. I wonder if it's implicated.
The '5.3.0 to 5.2.5 downloader' version of 5.2.5 has worked well, the second link here : Custom Firmware Downgrader 5.3.0 Chinese to 5.2.5 English
 

KenK73

n3wb
I gave your 5.2.5 a shot and got the same results. It goes in to 5.2.5 ok, but anything above that just puts the camera in mini-system mode.
 
I've taken this program, run through all the options and works as advertised, so kudos wzhick for publishing this and good to see fellow hackers contribute what they know.

Changing the firmware flag to English and loading English firmware will not make your camera English. What I did is replaced the IEfile.tar.gz with the one I previously offered in English and Russian, created a new digicap.dav file with this tool and did a firmware update and a Chinese camera now has English or Russian menus. Don't confuse that with making the region code permanently English and with just that fix alone, the day of week is still in Chinese but this takes the development process to the next level and feel we are close to better solution.

For those working on this effort, I found that a firmware update, besides updating files in the dav directory, also updates MTD9 & 10 via a file called himage in the firmware as well as MTD11 & 12 by a file called hroot.img. I feel somewhere in there is the key to the Chinese day of week problem.
hello my friends i can not using Blue iris Tools can you do me a favor ?
 

KenK73

n3wb
Welp... I am about to fling this mother hucker into the trash...

I tried setting the MTD1 to 01 and it worked... until I rebooted and it went back to the mini-system. I got it up to v5.3.0 and then v5.4.0 direct from the raptor 5.2.5. I would have tried to overwrite the MTD1 and MTD6 again under 5.4.0, but apparently the SSH option is removed in 5.4.0, so I couldn't do anything.

I then tried the exact same steps, but using an MTD1 of 02 just in case, and that just boots into half a mini-system (192.168.1.64 IP, but nothing works).

So yeah... I think I will just buy some legit WR domes and be done with this stupidity.
 

Habib

n3wb
can anyone help me by teamviewer about my problem, and anyother method of flash firmware of ds-7332hghi-sh with rs-232.
 
Top