What is causing this pulsating video (DH-SD59225U-HNI)

erkme73

Getting comfortable
Joined
Nov 9, 2014
Messages
848
Reaction score
410
I'm pretty certain this is a camera issue and not my BI configuration, but I've been proven wrong on so many other things, I'm just gonna toss this out there...

The pulsing every 1/2 second or so of clarity and blockiness seems to be intermittent based on how much movement there is in the frame. I recall seeing it when watching it on the camera's GUI - not just on BI.

Here are my settings:

upload_2018-8-31_20-18-50.png

I've tried higher bit rates, CBR, and even set the i-frame to be equal to the frame rate. Still, I get this:


That's extreme and frequent (presumably due to the rain) but even on less dynamic scenes, I still see the pulsing:



It's almost like a focus issue. It builds up to razor sharp, then bumps back to down to blocks. Is there no setting to keep the clarity all the time?
 

fenderman

Staff member
Joined
Mar 9, 2014
Messages
31,376
Reaction score
10,325
Try CBR....I know that @Cameraguy has the same issue that seems to occur during auto tracking...may be a firmware issue.
 

lulu5kamz

Getting comfortable
Joined
Sep 14, 2015
Messages
674
Reaction score
971
I was going to suggest going with the factory defaults for this camera and see what happens. It's not clear if you had tried this or not.
 

SkyLake

Pulling my weight
Joined
Jul 30, 2016
Messages
317
Reaction score
219
Look if ROI (Region Of Interest) is enabled in the settings. If so, disable it or click on remove all to remove the region. Then save.
 

awsum140

Known around here
Joined
Nov 14, 2017
Messages
1,283
Reaction score
1,123
Location
Southern NJ
I had a similar problem using UI3 in earlier versions of Fire Fox, so it could also be browser related. You don't mention how you're viewing the video so just tossing this at you as food for thought.
 

wopi82

Getting comfortable
Joined
Feb 9, 2017
Messages
92
Reaction score
449
Location
Poland
Nothing to worry about. You just messed up codec settings. Your image is loaded with ton of detail (ruble on the road, grass, pouring rain) and you use ridiculously low bitrate. So the codec freaks out. First turn on smart codec. Secondly, always use constant bitrate and set I frames to 20 (every second). And lastly, use maximum bitrate or at least above 6Mb/s. This will surely help.
 

SouthernYankee

IPCT Contributor
Joined
Feb 15, 2018
Messages
2,331
Reaction score
1,352
Location
Houston Tx
Wobi82: I disagree.

Always use VRB it improves the quality. Also the smart codex causes problems do to each vendor doing it differently, so keep it off.

What is the difference between CBR & VBR encoding? - Encoding.com

I would also increase the max bit rate.

In the pictures above what is the camera zoom set to ? At a high zoom it may be trying to focus. Is the lens and lens cover super clean?

Where is the camera mounted ? Is there any glare or movement in the light source need the camera.
 

Pmedicj

Getting the hang of it
Joined
Apr 8, 2018
Messages
114
Reaction score
48
I had this issue with mine after playing with the image settings a bunch. Did a factory reset and all went back to normal. The lower the bit rate the more pulsing. also bump up the quality setting on VBR.
 

wopi82

Getting comfortable
Joined
Feb 9, 2017
Messages
92
Reaction score
449
Location
Poland
Always use VRB it improves the quality.
Sorry, but this is not true. VBR is meant to keep your file smaller, while trying to keep motion parts of the image in better quality than static scenes. In case of Dahua this is only 1-pass VBR so coding is based on average quality setting, and not analysis of footage like in case of 2-pass VBR. Also remember, that VBR in this case will only use bitrate from fixed range and never exceed it. So for 2Mbit/s average bitrate it might use 3Mbit/s for motion part, while CBR would be 2MBit/s all the time. From my experience I can tell you, 1-Pass VBR is always more willing to lower your bitrate, rather than rise it. It will NOT give you better quality if you use higher bitrates, and you will more likely see degradation of the image in static parts.
 

NoloC

Getting comfortable
Joined
Nov 24, 2014
Messages
683
Reaction score
414
I have seen this to a lesser extent and believe it is when an I frame comes along and as @wopi82 stated , bit rate is too low and codec freaks out. Indulge me here and set the I frame interval to 100 and see what happens. I am curious. Also would increase bit rate and cbr, but would be very interested in I frame test at 100.
 

bp2008

Staff member
Joined
Mar 10, 2014
Messages
9,170
Reaction score
6,397
Location
USA
When the video suddenly becomes low quality and recovers in a regular pulsing pattern like this, it is because the i-frames (keyframes) are too low of quality. If it happens during live view in the camera's web interface, VLC media player, or Blue Iris's local console, then it is the camera's fault. Increase the bit rate, consider reducing the frame rate, and increase the i-frame interval.

If it happens in recordings but not in live view, then Blue Iris might be configured to re-encode video -- change it to "direct to disc" instead to prevent the quality loss.

If it happens during Blue Iris remote viewing via browser or mobile apps, then you need to increase the streaming bit rate in Blue Iris or in UI3, and increase the keyframe interval to max. Only set keyframe interval to max in Blue Iris or UI3's streaming configuration; don't do this in the camera's web interface.
 

guykuo

Getting the hang of it
Joined
Jul 7, 2018
Messages
95
Reaction score
82
Location
Sammamish, WA
I agree with others that your bitrate is too low. The codec simply can't squeeze in enough detail for the i-frames. I would at least double your bit rate to bring things into reasonable range for good quality encoding. This is security camera encoding and that can mean the codec sacrifices quality first before dropping frames (when available bitrate is insufficient)
 

Pmedicj

Getting the hang of it
Joined
Apr 8, 2018
Messages
114
Reaction score
48
I just played around with my i frame and it does have this pulsing effect. Reset your codec to default, increase your bit rate and it should go away.

I have mine set at 30fps I frame = 60 VBR 6 and 4096 bit rate. Nice smooth video.
 

Fred2000

Young grasshopper
Joined
Feb 15, 2018
Messages
36
Reaction score
18
Location
Germany
The SD6CE245U-HNI has the same problem. The highest value that can be set at the bit rate is 5000 kbit. The SD49225T-HNI is not affected. It is frustrating that the Pro camera that costs twice as much as the Lite is not able to deliver the same image quality.
 

lulu5kamz

Getting comfortable
Joined
Sep 14, 2015
Messages
674
Reaction score
971
The SD6CE245U-HNI has the same problem. The highest value that can be set at the bit rate is 5000 kbit. The SD49225T-HNI is not affected. It is frustrating that the Pro camera that costs twice as much as the Lite is not able to deliver the same image quality.
This is the Bit Rate I'm running on my SD6CE245U-HNI

DH-SD6CE245U-HNI Bit Rate.JPG
 

bp2008

Staff member
Joined
Mar 10, 2014
Messages
9,170
Reaction score
6,397
Location
USA
Have you tried Smart Codec? I tried it briefly yesterday on one camera and it did appear to improve quality somewhat, but it takes away the I Frame Interval setting. Looking closely at the video it kind of looks like it might not be doing full/complete iframes so I don't know what implications this may have for seeking or direct-to-disc recording in Blue Iris. It did seem to decode just fine in Blue Iris though! This might eliminate the pulsing problem.

I also noticed yesterday that enabling a region of interest (ROI) over the entire video frame at maximum quality appears to completely un-cap the bit rate. At one point last night when I turned off noise reduction, I saw my 2MP@15 FPS stream exceed 50 Mbps bit rate. But I was streaming it to two places at the time which no doubt saturated the 100 Mbps network port because it started dropping frames. LOL
 

SouthernYankee

IPCT Contributor
Joined
Feb 15, 2018
Messages
2,331
Reaction score
1,352
Location
Houston Tx
The original poster has not posted any additional information. Ask for help, then do nothing.
 

guykuo

Getting the hang of it
Joined
Jul 7, 2018
Messages
95
Reaction score
82
Location
Sammamish, WA
Hopefully ,will report back. I find this a common issue on many forums.
Newbie asks for advice. People spend time and put effort into giving good information only to be rewarded with the OP never appearing again.
After a few rounds, the experienced members quit responding after being burned out.
 
Top