IP Cam Talk

Welcome to the new IPCT! If you are having an issue logging in, please clear your cookies / cache.

Blue Iris UI3

Roman

Getting the hang of it
Web:

BI Local Console:

BI UI3:
 
Last edited:

bp2008

Staff member
That is quite a difference.

There are a few things to check. First look in the camera properties in Blue Iris, on the Video tab. Make sure "Anamorphic" is not checked. Make sure "Area of interest" is not checked.

It could also be that Blue Iris is pulling a different stream than you are seeing when you view in the camera's web interface. Double-check the resolution of the camera reported by BI (should be on the camera properties > Video tab just above the Anamorphic checkbox) and make sure it matches the main stream of the camera. The main stream should be set to the camera's largest resolution choice.
 

Roman

Getting the hang of it
@bp2008 Anamorphic and Area of Interest are not checked. However in regards to your second observation, the web log in for the camera shows the main stream set to the highest resolution of 2688 * 1520 and BI console shows 1920 * 1080 and it is grayed out and not sure how I would change it. So it appears BI is not pulling the main stream from the camera settings for whatever reason?

***Disregard***

I figured it out. Stupid me just assumed that since it was basically a rebranded Hik cube that I could use Hik as the manufacturer. Once I changed the brand from Hik to LTS it pulled the correct Main stream and looks like it should in BI now.

Thanks for helping me troubleshoot. Appreciate it!
 
Last edited:
@ToBeFrank UI3 doesn't handle it very well when the clip you are viewing is still being recorded (and is getting longer). This is most often an issue when you have the "Combine or cut video" setting enabled for the camera in Blue Iris. Is it possible this is all that is wrong? Does it only happen for alerts that appear in the most recent clip file?
This is a bug in ui3, and I have it fixed in my fork. Do you accept pull requests?
 

jaydeel

BIT Beta Team
I’ve discovered an issue with UI3 in Safari from my iPad (iOS 12.1.3). This issue occurs only when I start UI3 from a desktop icon created via Share>Add to Home Screen. When I take a snapshot, the image appears in full screen from which there is no way to get back to the UI3 interface. I must close UI3 entirely.

If I instead start UI3 from a bookmark in Safari, then the snapshot is displayed in a new tab, so it’s easy to get back to the UI interface. Chrome on my iPad behaves the same way. (I cannot test Chrome’s behavior from a ‘Home Screen” icon, as this feature is not available in Chrome for the iPad.)

If I use Chrome on my Android device, whether started from an in-browser bookmark, or from a desktop icon, the snapshot jpg is immediately downloaded with a flash message.
 

bp2008

Staff member
Apple has crippled web browsers on iOS for reasons known only to them. So it doesn't really surprise me that it reacts to an image download like that. Nothing I can do, really.
 

JayS_IPCams

Young grasshopper
Am i missing something... can't seem to control my camera's Iris via BlueIris/UI3
I can do it via tinyCam Pro on my phone... but soon as I move the camera via UI3 (or wherever) the Iris resets. So on cloudy days, I have to load up tinyCam to change iris settings to that details are better whenever I want to move the camera. (also found that the camera auto resets the Iris, so would love to be able to control it via BI/UI3).

for my SD49225T-HN camera.

Thanks!
 

bp2008

Staff member
UI3 can only do a subset of the things Blue Iris can do. You'll have to ask the Blue Iris developer for iris controls, or reconfigure some of the presets to send Dahua API commands to adjust the iris.
 

MrGlasspoole

Young grasshopper
I can't figure out how to open UI3 without the need for a user/password.

If i set "Require from: No connections" it works.
But "Non-LAN only" does not work.

The BI machine is 10.1.0.10/16 and my workstation is 10.1.1.1/16 - so it's the same LAN
 

TonyR

IPCT Contributor
I can't figure out how to open UI3 without the need for a user/password.

If i set "Require from: No connections" it works.
But "Non-LAN only" does not work.

The BI machine is 10.1.0.10/16 and my workstation is 10.1.1.1/16 - so it's the same LAN
Go to "options", "users", check box for user "anonymous", then click on "OK".

I then suggest you then edit user "anonymous" by checking "LAN only" box, then click on "OK", and set your "require from" authentication back to "Non-LAN Only" and that "insure secure session keys" is checked.

Lastly, restart Blue Iris.
 
Last edited:

TonyR

IPCT Contributor
The BI machine is 10.1.0.10/16 and my workstation is 10.1.1.1/16 - so it's the same LAN
No, it's not the same LAN unless there's a typo.
10.1.0.10/16 and 10.1.1.1/16 are on different subnets.

EDIT: we went over the anonymous user thing back in December 2018; did that not work out?
 
Last edited:

MrGlasspoole

Young grasshopper
It is.

10.0.0.0/16 is 10.0.0.1 up to 10.255.255.254.

My network works. All devices communicate without problems.

10.1.1.1 - 10.1.1.254 are my PCs/Consoles
10.1.253.1 - 10.1.253.254 are my Virtual Clients
10.1.254.1 - 10.1.254.254 are my DHCP Static Mappings
10.1.255.1 - 10.1.255.254 is my DHCP Pool

Online IP Subnet Calculator
 

bp2008

Staff member
I wouldn't be surprised if Blue Iris doesn't check the subnet mask properly. That is what it sounds like.

You can work around this using the "Limit IP addresses" box in Blue Iris Options >Web server > Advanced.

Blue Iris help file said:
The Limit IP addresses box provides a basic firewall capability for the web server. If left blank, or if there are no specific inclusions, all IP addresses are allowed to connect if not specifically excluded. To add an included IP address or range of addresses, just enter the IP address, optionally preceded by a + (plus). Use the * character in place of a number as a wildcard. To add an excluded IP address or range of addresses, precede the address with a - (minus). Separate multiple addresses with either a comma or a semicolon. Here are some example:

+192.168.*.* allow all typical LAN addresses
-58.*.*.* deny any address beginning with 58.
+68.77.123.1 allow this one specific Internet address
^68.22.1.* allow a range of IP addresses AND skip authentication with admin access (use carefully)
The final modifier character (^) will allow the addresses to skip authentication.
 
my UI3 has suddenly been telling me i can only use JPEG low, JPEG SD or JPEG HD
Chrome updated yesterday

UI3 version 65, Blue Iris version: 4.8.5.0

UI3 is a web interface for Blue Iris
Some optional features are not supported in this browser:
  • The H.264 video player requires these unsupported features:
    • WebGL
  • The audio player requires these unsupported features:
    • H.264 Video Player
  • Exporting clips to AVI is not supported.
The following video players are supported in this browser:
  • Jpeg
UI3 is designed for use with:
Google Chrome
 

Attachments

MrGlasspoole

Young grasshopper
+10.*.* does not work.
^10.*.* does work but i guess its something i don't want?

It also would mean i also have to add ^192.168.*.* because the OpenVPN tunnel network is assigning 192.168.44.1 - 192.168.44.254 to the clients?

we went over the anonymous user thing back in December 2018; did that not work out?
It did not work and that's the reason i'm now looking at it again.
 

bp2008

Staff member
my UI3 has suddenly been telling me i can only use JPEG low, JPEG SD or JPEG HD
Chrome updated yesterday

UI3 version 65, Blue Iris version: 4.8.5.0

UI3 is a web interface for Blue Iris
Some optional features are not supported in this browser:
  • The H.264 video player requires these unsupported features:
    • WebGL
  • The audio player requires these unsupported features:
    • H.264 Video Player
  • Exporting clips to AVI is not supported.
The following video players are supported in this browser:
  • Jpeg
UI3 is designed for use with:
Google Chrome
Sounds like somehow your WebGL feature got disabled. See if it is disabled in chrome://flags/
How To Enable WebGL on Google Chrome
 
Top