DH_NVR5XXX-4KS2_MultiLang_V4.001.0000000.1.R.200319.zip

EMPIRETECANDY

IPCT Vendor
Joined
Nov 8, 2016
Messages
3,608
Reaction score
7,217
Location
HONGKONG
The latest new fimware has been released, this is the best version that we have now for the 5 series.

Suit models
Models with V2 devices only , with logo or no Logo, all suits. No plugin now. V2 devices for those devices you bought after 2019.
NVR5232-4KS2,
NVR5208-4KS2,
NVR5216-4KS2,
NVR5232-8P-4KS2e,
NVR5208-8P-4KS2e,
NVR5216-8P-4KS2e,
NVR5216-16P-4KS2e,
NVR5232-16P-4KS2e,
NVR5416-4KS2,
NVR5432-4KS2,
NVR5464-4KS2,
NVR5416-16P-4KS2e,
NVR5432-16P-4KS2e,
NVR5464-16P-4KS2e,
NVR5816-4KS2,
NVR5832-4KS2,
NVR5864-4KS2,
NVR5816-16P-4KS2e,
NVR5832-16P-4KS2e,
NVR5864-16P-4KS2e,
NVR5424-24P-4KS2,
NVR5224-24P-4KS2,
NVR5208-8P-4KS2E

Bug Fixed
1. Fix local summer time, last of week cannot be saved
2.Fix abnormal translation of Greek ivs.SearchAgeDetail, causing abnormal AI function on the face
3. Fix occasional local GUI stuck problem
4. Fix file system quota crash
5.Fixed the issue that the overseas version of the overseas Le Orange Imou overseas neutral P2P is not online
6. Simultaneously fix SessionID hijacking login device reported by German researchers
7. Repair [WEB] format hard disk and U disk authentication, use clear text password transmission

Thanks to @Wildcat_1 ,@redfive @jmcu testing, till now no big problem.

Andy
 

Attachments

Last edited:

Wildcat_1

Getting comfortable
Joined
Dec 9, 2018
Messages
647
Reaction score
984
Location
US
@EMPIRETECANDY, I’ve tested this for a day now and has been rock solid. Fixes the GUI hang / crash that I saw in the Feb firmware. No issues so far and brings a lot of new features and updates to GUI since the December version.
 

EMPIRETECANDY

IPCT Vendor
Joined
Nov 8, 2016
Messages
3,608
Reaction score
7,217
Location
HONGKONG
@EMPIRETECANDY, I’ve tested this for a day now and has been rock solid. Fixes the GUI hang / crash that I saw in the Feb firmware. No issues so far and brings a lot of new features and updates to GUI since the December version.
They fixe up the bugs on the Feb. firmware, maybe these engineers are working hard now to keep their jobs!
 

redfive

Pulling my weight
Joined
Apr 13, 2016
Messages
398
Reaction score
162
Installed on a couple of 5208-8P-4KS2, and one 5216-4KS2, no issue so far, everything seems smooth
 

Wildcat_1

Getting comfortable
Joined
Dec 9, 2018
Messages
647
Reaction score
984
Location
US
I reported an issue to @EMPIRETECANDY that I'm seeing on a 5216-4KS2 where the GUI will still hang (as I saw in February firmware). This time it lasts a little longer, around 12 hours but then the unit locks (still see live video but cannot login locally, all frozen) and also web GUI access is also frozen. Replies to pings etc but again, frozen unit so looks like something is still hanging up the GUI. Revert back to December firmware and no issues at all. Just posting to see if any others are having issues like this or not ?
 

Slacker

Getting the hang of it
Joined
Feb 3, 2018
Messages
57
Reaction score
37
I am seeing this 'Download Certificate' with the different firmware's from 2020. I'm not 100% sure when Live View stopped working but it was initially working on the version 4 firmware. This is from model NVR5432-16P-4KS2 (not 4ks2e)

Everything still seems to work fine from SmartPSS. @EMPIRETECANDY thought it might be because 4ks2 is older hardware but I know it was working after the initial change to NVR v4 firmware.

Has anyone else seen this or have ideas? (I have not factory reset or defaulted anything since the last update and I don't want to since I am 4,000 miles away from the site.)



1585948136347.png
 

nosnim

n3wb
Joined
Oct 27, 2018
Messages
21
Reaction score
11
Location
Texas
Thank you Andy. Just upgraded 3 of my 5216-4KS2's about 30 mins ago. Hope there are no major bugs.
 

highground

Young grasshopper
Joined
Apr 22, 2015
Messages
31
Reaction score
6
Just sharing my experiences so far on this firmware:

Have twice now found that the NVR has reset it's static IP address on a different subnet to 192.168.1.108 from the correct address. No human intervention, not a DHCP or router issue....

I also had it lock up when trying to enter the main menu.

It worked okay for about a day or so before this happened on the new firmware; suffice to say I've also moved back to a 2019 version.
 

nosnim

n3wb
Joined
Oct 27, 2018
Messages
21
Reaction score
11
Location
Texas
It's been past 24-hours for me, everything still working good for my 3 x 5216-4KS2's.
 

Jagradang

Getting the hang of it
Joined
Aug 10, 2017
Messages
127
Reaction score
29
updated to this yesterday. I was previously on v3 and it kept loosing all my cameras. I tried just the update, backup factory reset and then restore but nothing worked. In the end i factory reset it and just manually setup all the configurations.

Been working great since (so far) after the facotry reset. will report any issues as i spot them.
 

Wolf4Ever

Getting the hang of it
Joined
Jan 22, 2019
Messages
66
Reaction score
32
Location
US
I reported an issue to @EMPIRETECANDY that I'm seeing on a 5216-4KS2 where the GUI will still hang (as I saw in February firmware). This time it lasts a little longer, around 12 hours but then the unit locks (still see live video but cannot login locally, all frozen) and also web GUI access is also frozen. Replies to pings etc but again, frozen unit so looks like something is still hanging up the GUI. Revert back to December firmware and no issues at all. Just posting to see if any others are having issues like this or not ?
I am on mine if you mean a white screen and can't login. Everything else is fine as in SPSS and iDMSS I can view and playback fine. Will go back to V4.000.0000001.2.R.20191101 as it's the latest one I had then update via NVR if needed.
Updating to V4.000.0000001.5.R.20191206 via NVR....so far same issue...so will default it and see if it helps or continues. Well seems to be working with IE for now but not new Edge/Chrome. Will watch it a day or two and try remotely and see.
 

Attachments

Last edited:

thundercam

n3wb
Joined
Mar 28, 2020
Messages
1
Reaction score
0
Location
US
I've got a DHI_NVR5216_4KS2

What's the difference between DH and DHI indicate, don't update using this firmware? Camera's were acquired from Andy but only work with the official dahua firmware on this NVR.. Tried to update and received black screens on the live monitor. Camera logs indicate NVR successfully login/logout
 

Reimo

n3wb
Joined
Feb 14, 2018
Messages
21
Reaction score
13
Location
Northern EU
@thundercam - The I in the label DHI, has no useful real meaning, when it comes to firmware. Origonally it indicates International model - sometimes it is in the label, sometimes not. Reset to Factory settings, remove "webrec" folder from computers "Program Files" and try again.
@Slacker - 4KS2 is not older, it is just without e-poe, and thats why it is with lower price. Software goes the same.
 

highground

Young grasshopper
Joined
Apr 22, 2015
Messages
31
Reaction score
6
I am on mine if you mean a white screen and can't login. Everything else is fine as in SPSS and iDMSS I can view and playback fine. Will go back to V4.000.0000001.2.R.20191101 as it's the latest one I had then update via NVR if needed.
Updating to V4.000.0000001.5.R.20191206 via NVR....so far same issue...so will default it and see if it helps or continues. Well seems to be working with IE for now but not new Edge/Chrome. Will watch it a day or two and try remotely and see.
I think that's a Chrome thing - does it work if you hold Shift and press F5 to refresh the page when on the white screen?
 

highground

Young grasshopper
Joined
Apr 22, 2015
Messages
31
Reaction score
6
I'm not sure if I missed it the first time, or if Andy updated the original post, but it does say V2 devices only, which mine isn't. So perhaps that's why I was having issues...? Mines a DHI-5216-4KS2 (V1.0).
Is there firmware for this v1 in the works Andy? Thank you.

EDIT: Just found this..... Is it suitable? Appears to be later version but not sure about model compatibility.
(Located here: Dahua Wiki)
 
Last edited:

weigle2

Getting comfortable
Joined
Dec 30, 2016
Messages
594
Reaction score
328
Location
Somewhere in the space/time continuum
I'm not sure if I missed it the first time, or if Andy updated the original post, but it does say V2 devices only, which mine isn't. So perhaps that's why I was having issues...? Mines a DHI-5216-4KS2 (V1.0).
Is there firmware for this v1 in the works Andy? Thank you.

EDIT: Just found this..... Is it suitable? Appears to be later version but not sure about model compatibility. (Located here: Dahua Wiki)
I would not use this for a V1.0 NVR5216. It probably won't install, anyway. Based on the name, it looks like it is designed for the "AI" series NVR's, as the name ends with -I . Also, it has the wording Human Temp in name, too. Try rolling back to your previous version to get full functionality back.
 

Wolf4Ever

Getting the hang of it
Joined
Jan 22, 2019
Messages
66
Reaction score
32
Location
US
I think that's a Chrome thing - does it work if you hold Shift and press F5 to refresh the page when on the white screen?
It sure does...now to update it back to the newest again...So I know F5 is refresh, but what the shift do?
 

molarbear

n3wb
Joined
Apr 21, 2019
Messages
13
Reaction score
1
Location
UK
Please could I just check if anyone here is having any success with push notifications to IDMSS or mobile apps? I've upgraded to this and only the odd 1-2 push coming through. I used to get many more back in September last year with an older IDMSS version but the app auto updated and since then very little in the way of push. I updated to this latest firmware and it's not really helped...

My NVR 5216 16P 4KSe was bought in April 2019, it took the firmware update fine, but it does say Hardware 'V1' in the about screen...?
 

Wolf4Ever

Getting the hang of it
Joined
Jan 22, 2019
Messages
66
Reaction score
32
Location
US
Please could I just check if anyone here is having any success with push notifications to IDMSS or mobile apps? I've upgraded to this and only the odd 1-2 push coming through. I used to get many more back in September last year with an older IDMSS version but the app auto updated and since then very little in the way of push. I updated to this latest firmware and it's not really helped...

My NVR 5216 16P 4KSe was bought in April 2019, it took the firmware update fine, but it does say Hardware 'V1' in the about screen...?
I have yet to have any luck as I always get a "failed to subscribe". When trying to setup any alarm message. I too would like to know how if possible to get it working.
 
Top