Ghosting . How to remove it ?

Discussion in 'Troubleshooting' started by Amgclk65, Apr 1, 2019.

Share This Page

  1. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    hey guys.
    I noticed a few of my video captures with a ghosting affect. Any insight how to remove it.
     
  2. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    30,211
    Likes Received:
    9,332
    how are you recording this video?
     
  3. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    I reposted with the correct link.
    Blue iris recording.
     
  4. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    30,211
    Likes Received:
    9,332
    I moved the thread to BI troubleshooting.
    You need to match the iframe interval in the camera to the fps. What camera is this?
     
  5. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    okay,
    its a hikvision DS-2CD2145FWD-I. would a screen shot of my setting page help? several Cameras in my setup exhibit this. in the past I've read the iframe rate needs to be half of the fps. Ill read up on iframe rate and see what I can come up with.
     
    Last edited: Apr 1, 2019
  6. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    30,211
    Likes Received:
    9,332
    do as stated above.
     
  7. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    Heres is the setting page of the hik that recorded the video.
     

    Attached Files:

  8. fenderman

    fenderman Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    30,211
    Likes Received:
    9,332
    Yes. Follow directions above. Also lower the bitrate by half, its insanely high.
     
  9. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    will do thanks.
     
  10. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    So I played around with iframes and didn't see any improvement. This all started after having to update my intel drivers. Ive tried both recommended drivers for 8th gen cpu's. No improvement with either drivers. Ive never had to mess with iframe rates to prevent ghosting in the past. I cant seem to find the previous drivers I was using. I do recall reading a thread on inserting specific files in the drivers folder to prevent memory leak. I cant seem to find that thread. Heres another video of the issue. System specs are z370n wifi with 8gb ram and i3-8350k. No overclock.
     
  11. Mike

    Mike Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    2,390
    Likes Received:
    1,534
    Location:
    New York
    What is your DNR and WDR set to? If DNR is above 50, try setting it to 50. As @fenderman said, make sure FPS matches I Frame and lower that bitrate to like 2048 or something.
     
  12. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    Ill have to check. Ive never changed them. It just seemed odd that now I have to tweak those settings.
     
  13. Mike

    Mike Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    2,390
    Likes Received:
    1,534
    Location:
    New York
    DNR is set to 50 out of the box, so if it's anything but, you or someone changed it. Try to out and see what happens.
     
  14. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    its at 50.
     

    Attached Files:

  15. Mike

    Mike Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    2,390
    Likes Received:
    1,534
    Location:
    New York
    Dude you need to set I Frame to match FPS. Change your I Frame to 15.

    upload_2019-4-9_22-48-9.png

    Then check DNR

    upload_2019-4-9_22-50-3.png
     
    fenderman likes this.
  16. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    I did have it at that prior to the Screen grab. I reset the camera and it went back to that. Its at 50.
    here's a camera with matching fps and iframe and still ghosting.
     

    Attached Files:

    Last edited: Apr 9, 2019
  17. Mike

    Mike Staff Member

    Joined:
    Mar 9, 2014
    Messages:
    2,390
    Likes Received:
    1,534
    Location:
    New York
    Okay, did you change the I Frame to 15?
     
  18. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    I did.
    Here is the video of the camera with matching frame and iframe rate.
    I trimmed that one to much. here's the correct video. I do take the advise on the forums and put it in play and actually try it and attempt to diagnose the issue myself.
     
    Last edited: Apr 9, 2019
  19. bp2008

    bp2008 Staff Member

    Joined:
    Mar 10, 2014
    Messages:
    8,418
    Likes Received:
    5,370
    Find the "Max rate" setting in Blue Iris camera properties > Video tab. Make sure it is a little above your camera's frame rate (15). Like 17 should be okay. BI is supposed to auto-adjust that but sometimes it doesn't work out quite right.

    Does this occur in live video or only in recordings?

    Some other things to try:

    Enable Direct to Disc recording, if you haven't already.
    Toggle hardware acceleration on or off for that camera. Do not use the "VPP" option for hardware acceleration.
     
    fenderman and Mike like this.
  20. Amgclk65

    Amgclk65 Young grasshopper

    Joined:
    Jan 14, 2018
    Messages:
    64
    Likes Received:
    5
    I’ve got the FPS at 16 in blue Iris. I can’t truthfully answer the ? Regarding live vs recorded events. I’ll have to look into that. Direct to disc is enabled. HW accel has been toggled on and off, with me trying different intel drivers.