Last Watch AI - a new platform-independent AI tool with web interface

kleypot

n3wb
Joined
Jan 28, 2021
Messages
18
Reaction score
19
Location
Florida
Hi kleyplot, I'm using a jetson nano for deepstack. I would test it out on the ARM64 platform. Is there a way to get it going? Thank's!
Does that board run Ubuntu or some similar flavor or linux? You should be able to run it. There is a config variable so you can change the endpoint for deepstack since you would probably want to run deepstack outside of docker to leverage the GPU. I don't have the hardware to test it myself but I'm happy to help troubleshoot, just open an issue on the github page.
 

kleypot

n3wb
Joined
Jan 28, 2021
Messages
18
Reaction score
19
Location
Florida
So I had some time tonight to take another look at this. I got the webUI working by installing the project under the first user rather than creating another one as suggested in the tutorial. I think I agree that there must have been a permissions problem before. The Samba share also works and I'm able to save images there. I checked through the mapped drive in windows and the command line in ubuntu that the files are getting to the /home/"username"/aiinput folder. I'm also checked that the file permissions are correct as per your suggestions in post #27.

The issue now is that the images are not being seen in the webUI. I've setup the UI as per the tutorial, but there is no indication that the program is looking in the right folder for the images. How can I check where it's looking?

The laravel.log file doesn't exist, which leads me to believe nothing is wrong with the program.

Thanks so much for the help and the great program. I'm looking forward to finally getting it working.

UPDATE:

I've been able to get over that last hurdle and now the program seems to be running properly. I'll have to monitor over the next few days to fine tune things.

I made a mistake in the trigger url and I can't figure out a way to modify or delete the bad web request automations. Perhaps that's a feature that should be added?

Thanks again guys for all the help and contributing to the community. Much appreciated.
I just pushed some changes including the ability to delete automations. Follow the Upgrade steps to pull the latest changes: akmolina28/last-watch-ai
 

nikonos

n3wb
Joined
Oct 23, 2019
Messages
2
Reaction score
0
Location
italy
Does that board run Ubuntu or some similar flavor or linux? You should be able to run it. There is a config variable so you can change the endpoint for deepstack since you would probably want to run deepstack outside of docker to leverage the GPU. I don't have the hardware to test it myself but I'm happy to help troubleshoot, just open an issue on the github page.
The Jetson Nano already runs deepstack in a docker container taking full use of the GPU.
I have opened an issue on the github page.
 

yusufptl

n3wb
Joined
Nov 5, 2020
Messages
7
Reaction score
1
Location
South Africa
Tried to install this today but ran into an issue.

It wants to Use port 9000 for one of the containers and that is already in use by my portainer, how can i fix it?

and Unifi controller is on port 8080
 

kleypot

n3wb
Joined
Jan 28, 2021
Messages
18
Reaction score
19
Location
Florida
You can edit docker-compose.yml to change the php port, e.g. change the line that says "9000:9000" to "9001:9000". It would be best to create an override file so that future updates don't undo your fix.

To change the web port from 8080 just edit the .env as shown in the setup instructions.
 

kleypot

n3wb
Joined
Jan 28, 2021
Messages
18
Reaction score
19
Location
Florida
New release day!



Thanks to some great feedback from this community I have made a lot of stability and performance improvements, along with adding a bunch of useful new features. Full details are on github and the blog post.

Thanks again for supporting my project!
 

warbux

n3wb
Joined
Aug 16, 2020
Messages
17
Reaction score
1
Location
United States
I have a basic installation on a local windows server that does not detect events despite copying the path to the watch folder directly from blue iris when I try to look at the deepstack and error logs they are blank. Any ideas?
 

kleypot

n3wb
Joined
Jan 28, 2021
Messages
18
Reaction score
19
Location
Florida
I have a basic installation on a local windows server that does not detect events despite copying the path to the watch folder directly from blue iris when I try to look at the deepstack and error logs they are blank. Any ideas?
Try setting WATCH_USE_POLLING=true in your .env file. Sometimes windows doesn't generate file system events so this setting might help.
 

Pentagano

Pulling my weight
Joined
Dec 11, 2020
Messages
373
Reaction score
176
Location
Uruguay
Interesting! Good to see new options to AI tools.

Has anyone done a side by side comparison with the deepquest AI fork tool?
 
Top