[tool] [tutorial] Free AI Person Detection for Blue Iris

IAmATeaf

Known around here
Joined
Jan 13, 2019
Messages
1,379
Reaction score
720
Location
United Kingdom
What ip address is reported if you ping localhost? Is that the same IP that your cams are connected to?

As said above the port that BI uses for its web UI is separate to the port that DeepQuest uses.

In my case, I too have dual NICs, I have the BI web server running on a selected NIC, my cams are connected via the other NIC. I have my BI web server on port 8081 and DeepQuest running on 8083, I use 8082 for another service.
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Not sure if this answers the question (when I Ping Localhost, all it does is say whether it was a successful ping or not, it does not return what IP address it is pinging)

So, my router is 192.168.1.1 sort of thing. The server I'm using for BI is 192.168.1.XX, and it is hardwired to a non-POE switch.

My cameras are connected to a POE switch that is connected to my router in the basement.

If I enter the dedicated IP for my BI server (192.168.1.xx) and the port 911, it takes me to the ui3 for BI.

If I enter localhost:911, it gives me that weird popup requesting a user name and password that takes me no where. I get the same thing if I enter 127.0.0.1:911 for instance, same weird popup.
 

IAmATeaf

Known around here
Joined
Jan 13, 2019
Messages
1,379
Reaction score
720
Location
United Kingdom
In your web server settings page for BI is the port number the same in all 4 settings that you blanked out when you posted a screenshot earlier?
 

IAmATeaf

Known around here
Joined
Jan 13, 2019
Messages
1,379
Reaction score
720
Location
United Kingdom
Try this command, change the port and credentials to match and try it with local host and then both up addresses for each NIC card you have installed and configured to see what you get back

Code:
http://localhost:port/admin?user=fred&pw=fred123
Edit: Why the hell is the above changing even when I enclose it with code? & should just be an ampersand.
 

xdq

Young grasshopper
Joined
Jun 12, 2017
Messages
48
Reaction score
18
Location
Newcastle upon Tyne
Just another thought, have you tried
Code:
http://user:pass@host:port/admin?trigger&camera=FrontDoor
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Try this command, change the port and credentials to match and try it with local host and then both up addresses for each NIC card you have installed and configured to see what you get back

Code:
http://localhost:port/admin?user=fred&pw=fred123
And use port 911 in each? I get the same popup every time. Whether I use localhost:911, 127.0.0.1:915, or 192.168.1.60:911.

Popup asking for user name and password.
 

IAmATeaf

Known around here
Joined
Jan 13, 2019
Messages
1,379
Reaction score
720
Location
United Kingdom
Are you getting any log entries in BI when you get the pop up?

I think I’m out of ideas now.

Are you running BI as a service, maybe try giving the BI service a restart if you haven’t already done so.
 

xdq

Young grasshopper
Joined
Jun 12, 2017
Messages
48
Reaction score
18
Location
Newcastle upon Tyne
Seeing the popup must mean that you're speaking to BlueIris so the ip/port are fine. It must be something do with the way that chrome is iteracting with the webserver.
yeah I just edited to post to put it in code quotes :)

I've just tried mine using Curl (curl for Windows) from the command line and it works as expected. You could give that a try to remove the browser from the equation.
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Restarted, tried again, this time I'm not even getting any error log in AITools. Maybe I will delete Deepstack, delete AItools, remove the additional network card, and start over as I'm beyond frustrated (but thanks for all your help guys!). This is mind boggling ...
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Seeing the popup must mean that you're speaking to BlueIris so the ip/port are fine. It must be something do with the way that chrome is iteracting with the webserver.


yeah I just edited to post to put it in code quotes :)

I've just tried mine using Curl (curl for Windows) from the command line and it works as expected. You could give that a try to remove the browser from the equation.
No clue how to use Curl, tried downloading it but I have no idea what it does or how to use it.
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Maybe I found something, When using the wizard to set up a webserver in BI, do I enter anything into local/remote port?

1593468235228.png
 

xdq

Young grasshopper
Joined
Jun 12, 2017
Messages
48
Reaction score
18
Location
Newcastle upon Tyne
As far as I know that shouldn't make a difference as you're connecting internally in the same way as you do if you were to view the webui from your pc. Again, seeing the username/password popup means that everything is communicating properly so it's possibly just a missing checkbox somewhere in the BI webserver or user settings.
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Okay will try that.. But have 3 user names and PWs and none of them work. Could it be because the password contains a #?
 

xdq

Young grasshopper
Joined
Jun 12, 2017
Messages
48
Reaction score
18
Location
Newcastle upon Tyne
Okay will try that.. But have 3 user names and PWs and none of them work. Could it be because the password contains a #?
Yes, I've just tried and see the same error. Special characters are a pain in URLs. I'd suggest choosing more simple but longer length and ticking the LAN only box on the user account.
 

pbc

Getting the hang of it
Joined
Jul 11, 2014
Messages
710
Reaction score
93
Yes, I've just tried and see the same error. Special characters are a pain in URLs. I'd suggest choosing more simple but longer length and ticking the LAN only box on the user account.
Just tried with test and test as user name and pw, made "test" user an admin, checked LAN...same friggin issue.
 
Top